Flash plugin in OpenSUSE 13.1 - Amazon Instant Video

I’m chagrined that I can’t get Amazon Instant Video to work in 13.1. When I try to play the video, it produces a message that the Amazon Player can’t be upgraded because I don’t have the latest flash. I DO have the latest Flash Plugin (flash-player- but I’ve noted the forum threads about HAL in 12.3, so I then installed hal-0.5.14-104.8.x86_64 from software.opensuse.org/package/hal. This gets a tiny bit further (yes, I started the haldaemon), but then the flash plugin just crashes.

Has anyone figured out how to get past this issue in 13.1?


Linux no longer gets flash updates from Adobe (besides security updates) so Amazon is basically complaining that the version number is not right (I think 11.9 is latest flash which probably has some features that the older version doesnt for DRM). Try using pipelight (http://fds-team.de/cms/pipelight-installation.html#section_1_4) or chromium with pepperlight-flash package installed.

you can use either chrome (or chromium + pepperflash from packman)
both use newer version of flash (currently 11.9 I think)
This may help - but there have been quite a few posts in the past from other users not being able to get Amazon video working, so I’m not sure if the newer flash will actually help you.

Pipelight is currently your besat hope for this, but it may or may not work, depending on your hardware.
Luckily there will be soon a new alternative called shumway on firefox, I cannot wait as this nonsense with flash is more then frustrating.

How is shumway progressing? Last I tried it there were problems playing some videos.

I had a play around a couple of weeks ago.
It is still a loooong way off being as usable as even adobe flash 11.2

I’m bumping this rather old thread because I am having issues with my Firefox Nightly. I installed Shumway and it shows up in the Add-ons-Tab, but it seems to not support YouTube-HD-Videos and movie streaming. Hence my question: What is the best alternative to Adobe Flash as of today? What do you geeks use out there? I’d prefer something Linux-native and in constant development (bleeding-edge freak writing this).

the only viable alternative to flash 11.2 found in linux is to use the pepperflash plugin in chrome or chromium.

The only 100% alternative to the flash 11.2 is pepperflash as stated above but you can try viewtube and viewtubeplus along with some media player plugin for FF to try on sites you visit.


WTF? Are you telling me that Firefox-Users are now FORCED to switch to an ugly Spy-Chrome and to use sh!tty scripts just to play flash videos as usually used to? Isn’t there some other project that attempts to work within FIREFOX NIGHTLY? I’d even use something very early stage, so please don’t hesitate to recommend something that is MAKING an effort to fully replace the standard flash stuff - I personally PERMBANNED Adove Flash from all my devices since I do NOT support their way of “smart thinking”. The way I see it: Developers are plain too lazy to even cope with Linux as they cannot accept the free licenses like GPL and probably earn about no money with developing for it. And let alone this fact, I am standing strong against this closed-source cr@p, this stubborn development for the masses, driven by money-hungry retards. So, any other project I should check out?

I’d even DONATE for a real alternative that strives to hit against and FULLY replace Adobe Flash on Linux in general and openSUSE in specific!

What are you using(instead flash)?

You can try pipelight if you want, it works with Firefox.

Flash 11.2 still works pretty well on the whole for most linux users. There’s no need to change to Chromium just for the sake of Flash. As far as I’m aware, there isn’t really anything pepperflash can do much better than 11.2 anyway.
It would be great to see flash consigned to history but we are still a few years off that happeneing - but it is happening slowly so I doubt you will see any great push to develop something for linux in what is really a dying technology. The greatest chance of an alternative is shumway - but it’s not clear if that will ever be a viable alternative - and if it does get to that point, then flash may already be almost gone.



I installed Shumway and enabled it in the browser settings, but it doesn’t seem to support 1080p YouTube videos and neither streaming.

You mean, I should install stuff from my MICROSOFT on my percious LINUX system? I refuse to do so.

Might be. But how about security updates? By the way: I already tried the normal flash install on my system - Firefox Nightly doesn’t recognize it.

Chrome would be the last browser I’d try. I refuse to let Spy-Google eat my data on my system.

As I already mentioned: I installed and enabled it - but it lacks support for most sites I visit. What do YOU use? Still Adobe Flash?

You are using the proprietary plugin one way or another I dont really see the issue.

‘pal’(thus between qm) You can use
http://www.srware.net/downloads/iron-linux.tar.gz (32-Bit)


With Amazon you may run into bans on different regions due to IP issues.

Would you please elaborate on what this is? I’d like to stick with Firefox Nightly while using the latest flash replacement…