Flash player

I am grateful for all our friends who helped in my previous thread.

Now my printer is working.

The firefox browser has a small hitch.

The flash player is not working.

I know the problem is that Adobe is not making one for 64 bit platform.

It asked me to download a file and install. I did that.
The installation worked fine.

However, the problems is still there.

I need your help.

I had this problem in the past.

A person in this forum helped me to solve the problem.

It was nearly 2 years ago.

If my memory serves well, his name is ‘leigh123’ and he lives in England.

If I understand correctly, you have 64 bit OpenSuse installed (including 64 bit FireFox) and the flash player doesn’t work.

If I understand the solution correctly, you will have to install 32 bit FireFox in order to have 32 bit FlashPlayer working.

If I understand the solution correctly, you will have to install 32 bit FireFox in order to have 32 bit FlashPlayer working.
Not True.
You can use _64 FF and Flash - it just requires nspluginwrapper

You should be installing via Yast and the repo’s really.

I thank bigrigdriver and caf4926 for the replies.

You have given me some clues to solve the problem.

First I will try what caf4926 has suggested.

Could you please tell me the exact name of the nspluginwrapper?

I will try to download it using YAST.

I have installed 64 bit open SUSE 11.0. My computer is a 64 bit one. The Firefox is bundled with the open SUSE 11.0 package. It should be the 64 bit version.

You say try to install.??

It really is easy.

Go to Yast - Software Repositories
use default (by url) next
Name: Mozilla
url: Index of /repositories/mozilla/openSUSE_11.0

You should also have in the repo:
Index of /distribution/11.0/repo/oss
Index of /distribution/11.0/repo/non-oss
Index of /update/11.0
these should be here by default

You might want to add (Packman)
Index of /pub/linux/misc/packman/suse/11.0

The thing is flash should just work out of the box. But anyway, now go to:
Yast - Software Management
Sort by Repositories (from the drop box-top left)
Select Mozilla
Now you should see the Packages for the Mozilla Repo on the right and probably you will see BLUE in the installed/avail column
Now go to the Package Tab (top left)
Go down the drop box to All in this List
select update unconditionally
check to see nspluginwrapper is marked as installed.
Click accept (lower right)

When done
Try FF

report back
if problem
open FF
in address bar type:


paste here

Thanks caf for the reply.

I didn’t find time to attend this today.

I went to work and went to the gym for training too.

I came home home almost an hour ago. I am tired now.

I will find time to do this tomorrow.

**Please keep a good watch on this thread.

I will ask your help if necessary.**

Today I found time at last to do this. I mean the step suggested byh caf4926.

Everything worked fine.

Finally I opened a webbrowser and wrote ‘about:plugins’.

The following is the output.

No plugins are installed
Find more information about browser plugins at mozilla.org.
Help for installing plugins is available from plugindoc.mozdev.org.

What is the problem?**

ok, you have the FF from OSS or the Mozilla repo I gave you - Yes?

Try installing Seamonkey and try it

also go to

check for


I was very busy for the last few days. Today I have some time to attend this.

I tried in vain this.

You asked me to do the following:

also go to


check for

You should give me the exact URL.
It doesn’t find /usr/lib64/browser-plugins.
Please tell me the exact URL.
I am waiting a reply from you again.

It should be something like the following URLs.

Index of /distribution/11.0/repo/oss

Index of /repositories/mozilla/openSUSE_11.0/x86_64


this is in your file system not the repo’s
open file manager and navigate there

I don’t find a File Manager in YaST Control Center.

Under the system icon I see an icon ‘Profile Manager’.

Where is the File Manager?

Now I found the place.

The following files are there:





OK so they are there
Now - are you sure you installed FF from the Repo - not manually?

Try konqueror too and use the find plugins in the settings
Also worth trying Opera browser if you have it installed

Gold, you now need to open a terminal as your user account and type the following without quotes “nspluginwrapper -v -a -i” That should install the plugins so that Firefox 64 bit can see them via nspluginwrapper.

I would like to install Opera via YaST Control Center. This helps to avoid all those unwanted dependencies.
Could you tell me the exact command to download Opera?

It is not installed by default.

How do I check plugins in Konqueror?


ni@linux-j5q7:~> su root
linux-j5q7:/home/ni # nspluginwrapper -v -a -i
Auto-install plugins from /usr/lib/browser-plugins
Looking for plugins in /usr/lib/browser-plugins
Install plugin /usr/lib/browser-plugins/nphelix.so
  into /usr/lib64/browser-plugins/npwrapper.nphelix.so
Install plugin /usr/lib/browser-plugins/libflashplayer.so
  into /usr/lib64/browser-plugins/npwrapper.libflashplayer.so
Auto-install plugins from /usr/lib64/browser-plugins
Looking for plugins in /usr/lib64/browser-plugins
*** NSPlugin Viewer  *** ERROR: /usr/lib64/browser-plugins/opensc-signer.so: wrong ELF class: ELFCLASS64
Auto-install plugins from /root/.mozilla/plugins
Looking for plugins in /root/.mozilla/plugins
linux-j5q7:/home/ni #

settings - configure K - plugins

What do you mean by settings?

In YasT Control Center I found an icon called Kernel Settings.

System → Kernel Settings.

Network Devices → Network Settings.
Please tell me the exact details.**

konqueror web browser
at the top - settings
configure konqueror

I saw a lot of plugins there.

The following are some of them.















You need to do it as your normal user, NOT root, it’ll work with root but your user accounts won’t be able to access the plugins.