flash player / video playing problem


Need your help. I am new to openSUSE and have this problem:

Everytime I attempt to play a video from any website it does not play.

Error from CNN:

" This …is optimized for Flash player…Install flash player"

Error from youtube:
“Hello, you either have JavaScript turned off or an old version of Adobe’s Flash Player. Get the latest Flash player.”

If I install the flash player, it is having yet another error telling me that it was already installed (because I have done previous installation already).

I tried to do plot commands in Scilab and the Graphics Window appears but there is no plot.

I think these problems are related. Can you help me on what to do to fix this? Thanks a lot in advance.


This post was originally posted in the wrong subforum area, and has been moved to multimedia in the hope of getting the user some support.

What version of openSUSE?

Open a terminal and do:

rpm -qi flash-player


uname -a

Post result


Thanks for the reply. When I tried the command you gave, it returned this :

“package flash-player is not installed”

Maybe that is where my problem is. Sorry, I am really new to this. Maybe the solution is simple but I honestly don’t know how to do it. I tried to do the installation but by just following/clicking from the website. Would appreciate your help on this.

By the way, the version of my openSUSE is: openSUSE 11.1 (x86_64)

Thanks again.

Open a terminal and become su
Become su in Terminal - HowTo - openSUSE Forums

From the terminal do this

zypper in flash-player nspluginwrapper

If this doesn’t do it please post result of

zypper lr -d


I was able to install as you said. However, when I tried to play the videos…still, it doesnt play but there’s no error anymore.

Thinking that maybe, I should have done the installation with no previously installed flash player…I tried to uninstall the previous one that I installed before together with the one I installed with the command you gave. And then I did the installation again as you said. However, still the same problem - video does not play but no error anymore.
By the way, I attached here the result of the query:

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
2 | repo | NVIDIA Repository | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.1/ |
3 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
4 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
5 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
6 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
7 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |
8 | repo_1 | Main Repository (Sources) | Yes | Yes | 99 | yast2 | Index of /source/distribution/11.1/repo/oss |
9 | repo_2 | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |
10 | repo_3 | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
11 | repo_4 | ATI Repository | Yes | Yes | 99 | rpm-md | http://www2.ati.com/suse/11.1

Thanks again in advance. I really appreciate the help.

Check if you have this installed


If it is, try deleting it

What happens exactly, saying it doesn’t work is not helping me understand. Maybe take a screenshot for us.

I would not be surprised of any errors you may face, as flash support in 64bit is spotty for some.
Of course not everyone has bad flash in 64bit but it is a well known issue.
Its not really a linux issue though, heck its spotty on windows too.
But there might be the possibility that CNN is not recognizing the linux version of flash or firefox… I dont use CNN but anti linux bias is very common.
Does youtube work?


I checked and there is no libflashsupport installed. Youtube and CNN behaves the same. When you click/play the video, it just displays a still and blank screen without an error.

I was trying to attach a screenshot here but I think there is no way. Anyway, I think it is not so very informative - just a simple blank dark/gray screen.

Thanks again. Hope you can help me find the solution.

BEst regards

Some folks in 11.1 had to remove the suse flash and install like this:

Flash Player 10 on 11.1 - Page 3 - openSUSE Forums

Worth a try
If you have trouble let us know


Thanks for this information. I am learning here.

It seems that this works fine for the 11.1 users in that thread. However, I followed exactly as decribed and I still got the same result.

Some interesting observations though:

this is the list of files after i added the plugin in the /usr/lib64/browser-plugins directory:

libflashplayer.so → newly added

When I looked into the FireFox Add-on list (plug-ins) I am not seeing anything in the list above. Instead, what I am seeing in the firefox plug-in add-on list are the following (I cannot copy so I just typed them here and could have typos). Totally different list.

DivX Web Player
GCJ Web Browser Plugin
NPAPI Plugins Wrapper 1.2.2
OpenSC Signer Plugin
QuickTime Plugin 7.2.0
Totem Web Browser Plugin 2.24.2
VLC Multimedia Plugin (compatible Totem 2.24.2)
Windows Media Player Plugin 10 (compatible Totem)
Shockwave flash 10.0r42

Question: Could it be that my firefox browser’s plugin is linked to a different path (than /usr/lib64/browser-plugins)? If it is, how can I check the path?

I tried to find the possible path/location of the items I saw in the Firefox plugins but I cant locate them. Maybe I cant guess the exact filenames. I tried wildcards also but to no avail.


  1. If I disable Shockwave flash 10.0r42 I see the original problem that I raised at the very beginning of this thread - errors showing up upon playing the video. If I enable Shockwave flash 10.0r42, I return to the new problem - video does not play and no error.

2)All flash related installations were removed from YAST.

3)Firefox restarts were done.

Thanks in advance. Regards

In a terminal post the result of

ls /usr/lib64/browser-plugins

hi, here it is:



please go to yast - software management and remove: nspluginwrapper


i did just that. but now, I am back to the original problem:

I tried to play/click a video in youtube and I got this error: "
Hello, you either have JavaScript turned off or an old version of Adobe’s Flash Player. Get the latest Flash player."

Just for my information, what is that wrapper doing? Thanks for the helping hand. I really appreciate it.


the wrapper is for the 32bit flash installed via yast.

you should have installed _64bit

What does this show now:

rpm -qi flash-player

Now I know :slight_smile: I checked in the Firefox plug-in list and I cant see the Shockwave flash 10.0r42 anymore. That is why I am back to the original error.

ok thanks…
here it is:
>> rpm -qi flash-player
package flash-player is not installed

hi caf4926,

where can i get the correct 64bit flash player and what is the best way to install it? thanks again in advance.

That’s OK then because if it was, that would be the SUSE flash.

The thing is, I could never understand why people have trouble with this, the default for me always worked. That is the SUSE flash packages with the nspluginwrapper. Always has, and is doing now in 11.2.

There are all kinds of tests I can think of but it depends how persistent you want to be on this.