Flash Player Video lags behind audio (ThinkPad A31p)

Well, I’m into my new system on an old laptop. I’ve enabled Flash Player and things are functioning but the video lags behind the audio output pretty seriously. Curious if there is any adjustment available for this condition that I can make and help resolve this issue.

13.1 KDE box w/ 32-bit

is it only flash video? what about video played in a media player? Is that fine?

Have you tried video on youtube with different resolutions? Could be your laptop just isn’t powerful enough to handle HD flash content???

thinkwiki says these laptops came standard with 256mb of ram. You would need to increase that for a start to have any kind of decent experience.
Fairly old ATI graphics adapter that may not be very well supported in linux (I don’t know but is something that might need to be looked into).

Yes, Flash video but others play fine on YouTube. VLC with other media is OK.

I just tried to play another vid and it slowed my system to a crawl but I was able to stop it, the system was responding slowly. Really weird.

Went back to it and the buffering was completed and fully loaded when I was able to play it without incident. Arrgh. I reported the slow loading to the website I was on, so maybe I’ll hear something. But I tried the same vid on my Win7 box and it played fine. So I’m sure it’s a condition that is limited to my new Linux configuration.

I think with 2GB RAM that I am OK there. I’m of the opinion that it has to do something with the buffering for sure. I am able to play the same video over and over without any difficulties once it has first loaded. I did notice that it was choppy when only 50-75% had loaded but once it reached the full 100% it was as I say fine.

Thanks for the assistance.

tbh I think it is probably just a limitation of your system specs. A 13 year old spec computer with ATI agp vid / 64mb vid ram is going to struggle.
KDE is fairly power hungry. You might have more luck with a lighter DE like XFCE or LXDE

Youtube usually auto detects the resolution your computer can handle and gives you that feed - so if you are struggling with flash content on other sites then I think you just don’t have enough grunt. Try switching to a 720p video in youtube and see if it is still OK.

You could also try disabling hardware acceleration in flash to see if that helps.

I have an old thinkpad (slightly oder than your but a little higher spec) that struggles with openSUSE. (although last time I checked was with openSUSE 11.3) :slight_smile:

Yes, seems that hardware acceleration being ON is the present culprit. I’m going to try the Vimeo website just now to see but I think I’ve found the more serious problem and its resolution.

BTW, my A31p is the 2653-R9U which is about as high spec as one could get back in 2003 when I purchased mine that summer. Right now I’m looking for some replacement speakers because my left one just went on the blink after all these years. I’m a high maintenance guy on less used equipment which makes for longevity and I just can’t pinch a buck hard enough to lose this my first laptop. It’s serving me very well at the time and I think that’s what it was designed to do. And, I just love the keyboard on it. One of the best and the LCD is the higher grade piece, too.

I wouldn’t worry too much about performance on Vimeo
Many modern computers struggle with their implementation of the flash media player.

You might also try Chromium and the pepper-flash plugin from packman and see if that behaves any better (much newer version of flash)

aside from that - video driver might also be worth checking out to make sure you are using the correct ati driver - if even there is one available for your card.

Vimeo is behaving better with the hardware acceleration turned OFF now. That’s what their tech support suggested, too, as a resolution. Guess they maybe get that a lot. :slight_smile:

I’ll put Chromium on the box soon and get back with the results.

Video Driver: Kinfo suggests it’s a Tungsten Graphic, Inc. (??) and gets the hardware correct. Not sure how to go about check for an alternate driver though.

So, I’m happier with the video performance but now I’m looking at having to replace my speakers in this laptop. For some reason they seem “blown” when I didn’t notice that on the Windows XP installation. Weird again. I’ve got some on order and am looking now for an instructional video to help with the disassembly. That’s another task that I don’t look forward to being that I’m a little older and less full of vim and vigor as I used to be. :slight_smile: We’ll see how that goes in another thread. Thanks for your kind assistance!

are you sure the speakers are broken?
Being an old computer it may just have problems with Pulse audio.
Try switching Pulse Audio off.

Yast > Sound > Other > Pulse Audio Config

and uncheck enable pulse audio support

OK, got that unchecked but still see the PCM Master volume control along with the primary Master and both affect my sound. I’m setting the primary at 100% and have to lower the PCM to 80% to prevent the speakers from being overdriven to distortion. Why is the PCM Master still there and affecting the sound if it is disabled? I’ve rebooted, too.

I would not expect much from such an old setup, in any case PCM is sort of like the master audio in certain setups and it really depends on your audio card.
As for flash, yeah its a pain in the butt as flash in linux is not supported anymore by adobe (stupid morons) so most flash issues (for now) will be solved by installing google chrome/chromium.
Luckily flash will die soon and be replaced by html5.

Using Chromium just now, my CPU supports SSE2 so I’m good there whereas my other box didn’t. But to the issue of PCM, I’ve been catching up on how to determine if the daemon is running or not and it would appear that it is NOT whether I have the checkbox enabled or disabled. And the left speaker is buzzing moreso that the right one it would seem. I’ve ordered some replacement speakers just in case but I don’t know how to go about checking each of the speakers individually to confirm if they are bad.

Anyway, thanks for jumping in here. Appreciate your doing so.


I just hooked up my earphones and things are working just perfectly with PCM enabled, too. The volume does get loud with each of the Master and PCM volume slider at 100% but absolutely NO distortion. This again leads me to believe that the speakers are somehow shot and not working as they should. I’m going to bone up on my disassembly skills and hope for the best when I go to try and replace them but I need to learn how to check the new speakers for sound quality before I install them, they’re used from Turkey (no less). Ha, never thought I’d see that and free shipping to boot. Wish me luck when I start. Thanks again!