Flash player update dependency problem

I received an update notice for flash player, but the update fails because it needs kdebase4-runtime <= 4.11.97. As far as I can tell, this package is not in the repositories.

I have the same problem, oS 13.1 x64, KDE 4.11.3.

Full error is:

nothing provides kdebase4-runtime >= 4.11.97 needed by flash-player-kde4-

Rgds, Jon

Have a look at your posts, who is posting correct output, they’re opposites.
And, I’d love to see output of

zypper lr -d

The error message in the first post has a tiny error that is very significant, the correct error message is in the second post. I get this when running updates too.

nothing provides kdebase4-runtime >= 4.11.97 needed by flash-player-kde4-

These are my configured repositories at the moment:

:~> zypper repos -pu
# | Alias                     | Name                               | Enabled | Refresh | Priority | URI                                                            
1 | repo-debug                | openSUSE-13.1-Debug                | No      | No      |   99     | http://download.opensuse.org/debug/distribution/13.1/repo/oss/ 
2 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | No      |   99     | http://download.opensuse.org/debug/update/13.1/                
3 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | No      |   99     | http://download.opensuse.org/debug/update/13.1-non-oss/        
4 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/13.1/repo/non-oss/   
5 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/13.1/repo/oss/       
6 | repo-packman-essentials   | openSUSE-13.1-Packman-Essentials   | Yes     | Yes     |   99     | http://packman.inode.at/suse/openSUSE_13.1/Essentials/         
7 | repo-source               | openSUSE-13.1-Source               | No      | No      |   99     | http://download.opensuse.org/source/distribution/13.1/repo/oss/
8 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | http://download.opensuse.org/update/13.1/                      
9 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | http://download.opensuse.org/update/13.1-non-oss/              

The output of ‘zypper info kdebase4-runtime’

Information for package kdebase4-runtime:
Repository: openSUSE-13.1-Update
Name: kdebase4-runtime
Version: 4.11.3-50.8
Arch: i586
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 19.9 MiB
Summary: The KDE Runtime Components
This package contains all run-time dependencies of KDE applications.

nothing provides kdebase4-runtime >= 4.11.97

This package isn´t anymore in the KDE4.12 Repo.
Do a

zypper dup --from "KDE4.12-Repo"

“KDE4.12-Repo” has to be replaced.

You have no KDE4.12 -Repo and therefore my last Post is unnecessary.


Sorry, my post contained a typo. The error is the same as the one reported by 6520302.

 nothing provides kdebase4-runtime >= 4.11.97 needed by flash-player-kde4-

You can actually delete flash-player-kde4
Without any harmful effects
This will resolve your conflict for now.
I don’t know if anyone actually uses the flash config anyway

A major credit card company uses Flash Player with their virtual card option.
When you say “flash config” do you mean the settings in flash player or something else?
Will flash player still function after removing flash-player-kde4?

Thanks, jon

flash-player-kde4 is just a module for KDE’s systemsettings (“Configure Desktop”).
So yes, flash player will continue to work if you uninstall that. And you still can reach the settings by right-clicking on flash content.

Thanks, that helps me understand

Deleting flash player kde solved it for me too, thank you guys.

The issue seems to be resolved already.
I was able to install the update without a dependency problem right now.

So if you want to you can install flash-player-kde4 again.

Not resolved yet for me - I’m still getting the exact same error message…

Well, it worked fine for me half an hour ago.
Maybe the mirror you got redirected to didn’t have the new package yet?

So just be a little patient, or ignore the conflict for now (possible if you use YaST->Online Update or zypper), or uninstall flash-player-kde4.

It was fine for me this morning.

On the one machine that I updated yesterday, I took the option to not install the flash update. I’ll install that today. On my main desktop, I updated this morning and all was fine.

Thanks - just worked for me to - this time the update seemed to include 2 packages - flashplayer and the kde-flashplayer…