Flash Player not detected by Firefox

Hello:
In my Leap 42.2, despite installed flash-player plugin version 24.x, yet some web site warn to “install latest flash-player.” Could someone help?
Thanks!

If it’s only one or two Web-Sites which are exhibiting this behaviour, then it’s an issue related only to those few specific web sites – which can almost certainly be ignored – after all, it’s only a warning . . .

My experience here in Europe, is that those Web-Sites which have not yet moved away from Adobe Flash are not causing the Adobe Flash-Player being used by Firefox running on Leap 42.2 systems to raise this issue.

You could consider setting-up the Flash-Player behaviour in Firefox to “always ask if Flash should be run” (which I believe is the default these days anyway). If you don’t allow Flash to run on the sites causing the issue, then they should change to an HTML-5 behaviour (like Android phones).

Sorry for delay! hve been busy during this holiday season.
Although yast showing flash version 24.x installed but when i go to this web site, is say flash is not installed. What is wrong?
Thanks!

Says it is installed here but had to allow site in noscript. You using any blocking software??

Well the problem is solved now.
What I did:
Removed the installed one in yast.
loged out- back in
run sweeper
reinstalled flash in yast
tried it by visiting the site again
Bingo!!!
It worked!
Thanks for your help.

I tried that site.

It tells me that flash is probably installed. Then it mentions that javascript is not enabled so it cannot tell for sure.

Okay, I’m using “noscript” (with firefox). So I temporarily allowed scripting for the site. It immediately switched to saying “Yes” (flash is installed).

I’ll note that I also use the “flashblock” extension, so flash won’t actually run until I allow it. But this did not faze the website at all. It can apparently tell that flash is there, even though blocked by “flashblock”.

Thank you, see my post above (post #5).

Did a ‘whois’ and ‘dig’ on “isflashinstalled.com” – also checked the reverse look-up with “dig -x” – you just can’t be too careful these days . . .

Then, I took a look at what the “real” Flash folks are offering: <https://helpx.adobe.com/flash-player.html&gt; – using Firefox, I activated the Flash Player “one time” for the Adobe site and guess what: it works like a dream – my Ghostery is set-up to trust the Adobe folks.

Took a deep breath and checked the “non-Adobe” folks: it also works (with Ghostery blocking the non-Adobe folks):

Is Flash Installed? Yes! Macromedia/Adobe Flash is installed!
Detailed results:
JavaScript Flash Detection Library:
Installed: Yes
Raw version: Shockwave Flash 24.0 r0
Major version: 24
Minor version: 0
Revision: Unknown
Revision string: r0
Adobe Flash Player Detection Kit (Client):
Type: Plugin (Non-IE)
Version: 24.0.0
Adobe Flash Player Detection Kit (Server):
Installed: Yes

Adobe Flash is installed as follows on this system:


 > LANG=C zypper info flash-player
Loading repository data...
Reading installed packages...


Information for package flash-player:
-------------------------------------
Repository: Aktualisierungs-Repository (Nicht-Open-Source-Software)
Name: flash-player
Version: 24.0.0.186-2.121.1
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 20.1 MiB
Summary: Adobe Flash Plugin
Description:
  This package contains Adobe's Flash Plugin for the supported Web
  browsers. On i586 platforms, a standalone flash player application
  is also included.
 > 

I don’t read good german but afik opensuse and adobe had a divorce regarding flash and opensuse no longer provides flash so this bit
Repository: Aktualisierungs-Repository (Nicht-Open-Source-Software)
looks strange to me, some users have repackaged it I’m not sure how the opensuse folks feel about that
https://software.opensuse.org/package/flash-player
you should get flash from packman

a full vendor change to packman would fix that

Oooops!!! Sorry! – Forgot to mention that the trace is from my 13.2 system.

Be that as it may, my Leap 42.2 system also has Adobe Flash installed but, from the Adobe repository:

BTW: It seems that Adobe have changed their “Flash Player for Linux” policy: looking at the following Adobe URL it seems that regardless of operating system (Redmond, Mac, Linux) FP24 is being offered: <https://get.adobe.com/de/flashplayer/otherversions/&gt;