Flash player in Firefox "grabs" audio and won't let go

Quick description:

When I run firefox and say, view a youtube video, the sound plays fine. However as soon as firefox plays any sounds, no other process (Amarok for example) can put anything out to the speakers. Firefox seems to have a lock on the sound.

If I’m running Amarok first and then try to view a youtube video, there is no sound from firefox.

Is this familiar to anyone? I will provide more details if necessary but thought I’d try a general question first.

I just created an account here so I could reply. So far, your post is the only result I’ve found via Google.

I’m running Slackware 12-something and having the same issue. My husband is running the same version of Slackware and is not having the same problem.

I’ll post back here if I find any answers.


Had the same issue on 11.0
As far as I can remember updating alsa or gstreamer solved it but I’m not sure.
Running 11.1 KDE4.2.3 now and watching flash videos with amarok music in the backround works just fine.
This is the list of installed packages that might have something to do with it :

amarok 2.0.2-6.2
MozillaFirefox 3.0.10-1.1.1
gstreamer-0_10 0.10.23-42.pm.1
alsa 1.0.18-8.7
libpulse 0.9.12-9.6

I’ve seen that sometimes, especially if fire fox is still running.

I find if one closes firefox, the problem will go away. I have also found that changing the audio output module in the multimedia player to an API that allows sharing of audio between applications, also means that even if flash-player in firefox has not let go the audio application, I can still play a video with audio in another application.

One can chose different sound engines with amarok. You need to tell us which amarok sound engine you are using that is causing you this problem. The same is true for any other video applications that are causing you this problem (of not sharing the audio). You need to tell us what output audio module you have selected.

This is not to say flash-player/firefox is not misbehaving, as I believe it is. But there are work arounds. Other applications with the appropriate audio output module selected, can play audio.

There is hope that Pulse Audio will eventually solve this sort of hiccup. Unfortunately Pulse Audio is still a bit immature, and has introduced its own hiccups.