flash player frustrations

on 11.1 (64 bit) - Mozilla just goes away when I click on a video to play. Just downloaded libflashplayer.so and moved it to /usr/lib64/browser-plugins per a thread here.

Thanks for any advice…

On my 64-bit openSUSE-11.1 with flash I note the following query results:

oldcpu@hal1000:~> rpm -qa | grep flash
oldcpu@hal1000:~> whereis libflashsupport
libflashsupport: /usr/lib/libflashsupport.so
oldcpu@hal1000:~> which flashplayer

I use firefox with mplayerplug-in, although I do note that mplayerplug-in is being depreciated.

linux-3jev:/usr/lib64/browser-plugins # rpm -qa | grep flash
linux-3jev:/usr/lib64/browser-plugins # whereis libflashsupport
libflashsupport: /usr/lib/libflashsupport.so
linux-3jev:/usr/lib64/browser-plugins # which flashplayer
linux-3jev:/usr/lib64/browser-plugins #

Not sure what to do here as I am a bit of a ‘newbie’. I note that across all the distros getting audio and video to work is a bit of a challenge.

While my 64-bit openSUSE works with libflashsupport, I note some users found removing libflashsupport enabled them to get flash working with firefox.

I don’t have flash-plugin installed - I don’t know if that matters if libflashsuport is removed.

You should also state what web site is giving you this problem? Youtube? CNN ? BBC ? Apple Movie trailer? All flash sites? … and if all, which ones did you try?

And what plugin are you using with Mozilla firefox? mplayerplug-in? gecko-mediaplayer? I use a version of mplayerplug-in packaged by Chrysantine.

But as noted above, mplayerplug-in (which fortuantely works for me because of Chrysantine’s packaging a recent SVN version) is being depreciated and replaced by gecko-mediaplayer (available from Packman: PackMan :: Informationen zum Paket gecko-mediaplayer )

I did not consider testing various websites - I tried to view a video on yahoo. I’ll gather answers to the other questions and return.

I appreciate your support, and please ignore my frustrated tone.

New users tend to struggle. But users who have been with openSUSE for a while tend to find it rather easy.

The first thing I typically do after a fresh install, after getting internet to function, is I setup my repositories for software with 4 and ONLY 4 repositories: OSS, Non-OSS, Update and Packman. Typically the 1st 3 are already setup and I just need to add Packman. Do NOT add any more. Only those 4: OSS, Non-OSS, Update and Packman. Just those 4. Adding more can add problems, that frankly, new users are likely not capable of solving (nor even identifying) the problems that can happen. And those 4 will give one a LOT of multimedia.

Then go to YaST > Software > Software Management and replace SuSE-GmbH packaged versions with Packman packaged versions of applications.

I never cease to be amazed by new users who have added a couple dozen repositories in the naive belief it will make things easier/better, when in fact it destroys their system. In Linux, LESS is typically better, as opposed to Windoze where more can be better.

I did say ONLY 4 repositories?

I am ecstatic - removing libflash support got my video working.

My problem is not really being a new user, but having experience similar to swiss cheese: lots of holes, lots of solid parts.

My first exposure to Unix was back in the early eighties. Being in the IT industry (using numerous platforms) I am not always in the mood to tinker, and Linux requires it. Rarely does something work right away.

The ‘newbie-ness’ is largely my fault for not applying myself more and conquering my impatience.

Thanks again for your support…

This is a pain this particular need to remove libflashsupport. I’m glad to read you have it working now.

I had this happen on our family laptop, where I had to remove libflashsupport to get flash working, and my wife (an WinXP) lover was NOT impressed when she saw me do that, as she ranted at me saying “how would a new user know that” ? To which I could only answer “ask in the openSUSE forums”.

Its a PITA that that is necessary in some cases.

You may find apple movie trailers crash your firefox. As noted mplayerplug-in is being depreciated, and its possible the gecko-mediaplayer works better? I don’t know.

I’ve done a fair amount of ‘distro hopping’ in the past few years and have finally settled on this one.

The others have all been appalling in one way or another.

I do depend heavily on the forums - and the folks in this one are more courteous and understanding.

It amazes me how much people do know and I wonder just how much time they have to learn it all ?

I confess the amount of knowledge that some of our guru’s do know does amaze me a LOT of the time.

But I sort of rationalize it this way, … in many cases (take myself for example) those who provide support on our forum have been using Linux for over a decade. I started in 1998 and have ONLY been using Linux at home since. One can not help but pick up a few things that way.

In 2005 I decided to return a bit to opensource, after doing nothing but take for free for over 6 years, … by 2007 I decided to start focussing on sound, as I noted there were major problems with many users there, and that was one area I knew a bit about. Of course the more support one gives, the more one learns. Plus by hanging out on the forums (given support to sound in my case) I would see other non-sound problems that were solved, and I would learn the solution.

But you know, thats not so unusual. I note many MS-Windows users have been using windows for over 2 decades, so its not surprising they know Windows well, and they can quickly point to MS-Windows solutions. And I think it also explains their frustration when coming to Linux and find their 1 year effort at Linux (when trying to use Linux) can not even come close to competing with 2 decades of Windows familiarity.

I myself am pathetic with MS-Windoze. My lack of familiarity with makes me a complete cripple when it comes to that OS.

If a forum is good (and we try here - albeit we do have detractors) then hopefully it will act as a good focal point for improved technical information flow.

I am not really a supporter of Windows but will point out that I have never had any problems with installations. There are of course shortcomings…

My career has been focused on mainframes, since 1968. It is amazing how people have pretty much forgotten them yet they run quietly in the backgrounds of major corporations, reliably, never crashing or locking up.

It’s important to learn as much as possible though - to remain employable… and I will continue to enjoy my Linux ‘journey’.

> It amazes me how much people do know and I wonder just how much time
> they have to learn it all ?

don’t be too impressed too easily, for it is is only a very few of us
who have actually learned it all! :wink:


Good to know.

OK then - next phase here is to be able to view .wmv and other video files. I just followed a thread that had me install a LOT of stuff, gstreamer, mplayer, etc. and the movies still do not play. Had this same challenge in Ubuntu as well till I stumbled on the right procedure.

How do I get the video file viewing working ?

Please ensure you followed the advice about 4 repositories and only 4 (above). ie OSS, Non-OSS, Update and Packman. Some details:

  • OSS = official openSUSE-11.1 repository with same rpms as are on the installation DVD
  • Non-OSS = 3rd party applications that Novell/SuSE-GmbH decided to package separate from the OSS. Typically these are proprietary in one shape/form/or-another and Novell/SuSE-GmbH are still packaging them, even though it is contrary to the open source free software goals of Novell/SuSE-GmbH
  • update = all the “official” Novell/SuSE-GmbH updates to OSS and Non-OSS
  • Packman = 3rd party repository with LOTS of multimedia. Note you can tell Packman packaged versions of an rpm by the “pm” in the version number

Now you are likely missing codecs. In openSUSE the codecs can be obtained by installing the Packman packaged libffmpeg0 (its dependencies will install the apps/libs that provide the codecs), w32codec-all, libquicktime0, libxvidcore4.

Hopefully those 4 codecs will get you started.

Reference media players, I recommend the Packman packaged version of “smplayer” (which will pickup MPlayer as a dependency). The packman packaged “vlc” also works good. I like installing the Packman packaged “xine-ui” together with the Pacmkan packaged ‘xine’ as the gui to xine can be useful for investigating configuration problems with “xine” (where many apps use xine as their sound engine).

Note, if you ignored my advice and included videolan as a repository (together with Packman repository), you will have problems with codecs.

It might be worth your while to read again this stickie (thru to the end):
NEWBIES - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums
… as it may answer some of you questions

Looks like I have a lot of reading to do, and quite a bit more challenges to getting multimedia working.

Most of the commands in the ten step guide I entered do not provide results matching the samples.

Not sure what steps to take to make them match.

Oh well… time to gather my patience…

I assume you are refering to this: Check your multimedia problem in ten steps - openSUSE Forums

Set up the 4 repos like I suggested. Only those 4. No others. None.

Then one by one, update the rpms/apps mentioned in the “ten step guide” to packman packaged versions. Again note one can tell packman packaged versions by the “pm” in the version number. Also note that guide is getting a bit old, so the version numbers in that guide will not be 100% accurate and may be dated. Go with my packman advice.

If one has had a problem, its likely because one has not followed the “only” 4 repos advice that I have given.

I’ve eliminated all but the four you mentioned… and re-initiated the install.

Thank you for your support.

OK - one step at a time. Here is the first one:

linux-3jev:/home/stan # LC_ALL=C zypper ve
Loading repository data…
Reading installed packages…
4 Problems:
Problem: gstreamer-0_10-plugins-bad-lang-0.10.13-42.pm.1.x86_64 requires gstreamer-0_10-plugins-bad = 0.10.13, but this requirement cannot be provided
Problem: gstreamer-0_10-plugins-base-0.10.23-42.pm.1.x86_64 requires libgstinterfaces-0_10-0 >= 0.10.23, but this requirement cannot be provided
Problem: gstreamer-0_10-plugins-base-lang-0.10.23-42.pm.1.x86_64 requires gstreamer-0_10-plugins-base = 0.10.23, but this requirement cannot be provided
Problem: libxine1- requires libmodplug.so.0, but this requirement cannot be provided

Problem: gstreamer-0_10-plugins-bad-lang-0.10.13-42.pm.1.x86_64 requires gstreamer-0_10-plugins-bad = 0.10.13, but this requirement cannot be provided
uninstallable providers: gstreamer-0_10-plugins-bad-0.10.13-42.pm.1.i586[Packman Repository]
gstreamer-0_10-plugins-bad-0.10.13-42.pm.1.x86_64[Packman Repository]
Solution 1: install gstreamer-0_10-plugins-bad-0.10.13-42.pm.1.x86_64 (with vendor change)

PackMan :: Startseite
Solution 2: Following actions will be done:
downgrade of gstreamer-0_10-plugins-bad-lang-0.10.13-42.pm.1.x86_64 to gstreamer-0_10-plugins-bad-lang-0.10.8-6.6.1.x86_64
install gstreamer-0_10-plugins-bad-lang-0.10.8-6.6.1.x86_64 (with vendor change)
PackMan :: Startseite

Solution 3: Ignore some dependencies of gstreamer-0_10-plugins-bad-lang

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/C]:

Accept the vendor change to packman packaged version.