Flash Player 10 on 11.1

i can’t guarantee that this will work for you, but it does for me (and
i just went from Flash 9 to 10 a couple of days ago, and it STILL works)…

see this posting and follow it, exactly…EXCEPT–see my note below
this link:



when you go to Adobe <http://get.adobe.com/flashplayer/?promoid=BUIGP>
you will find that they no longer offer a “debug version” as specified
in the forum post…a couple of days ago i downloaded the version
called “tar.gz for linux” which resulted in a downloaded file named
“install_flash_player_10_linux.tar.gz” which has inside the 9.7 MB
file named “libflashplayer.so” and a “flashplayer-installer” file
which i ignored as directed in the forum posting…

should work…does here…if it does not there then you have worse
problems than a flash that does not work…

good luck…

CAVEAT: The author of this posting does not warrant the accuracy,
completeness, legality, or usefulness of its content and is not
responsible for consequences resulting from its use.

You could try using the alpha version of the 64-bit flash plugin. I’ve been using it since last december, and it works about as well the 32-bit plugin does.

To get it working:

  1. Remove all installed flash related packages in YaST software management.
  2. download the plugin here
  3. Extract the plugin, and place a copy of it in /usr/lib64/browser-plugins
  4. Restart firefox. Check that firefox sees the plugin by looking in the Add-ons.

IMO, it sounds like the problem you are having has to do with the plugin wrapper. Before the 64-bit version of the plugin came out, I was constantly fighting with the wrapper to get flash working.

Thank you so much, srschifano! That worked for me! Now I can watch countless hours of funny YouTube videos again! :wink: Though, I’m still curious as to why the flash player/nspluginwrapper from the repos didn’t work… oh well.

There are probably tons of reasons why the wrapper doesn’t work. It is, after all, a wrapper designed to get a finicky plug-in of one architecture to work on another. The possibilities for the whole thing breaking are great.

I am happy to assist! :slight_smile:

I’ve got some problems with flash as well.
On some websites the sound is very weird (when I watch videos in flash) whereas on some it is fine.
I tried Konqueror and it is the same…

Some have found removing libflashsupport fixes it.

With a list of repos that large, I would be very surprised if there are not many things that do not work. IMHO such a large repos list is a recipe for non-functionality.

I typically recommend ONLY OSS, Non-OSS, Update and Packman repos.

I had no sound from Youtube or some games in Facebook. The 64 bit plugin solved the problem. Thanks to all.