Flash playback choppy.

I’m getting choppy playback in flash, 32bit. It’s fine until I go fullscreen. Anyone have any ideas? I was thinking of installing the 64bit version of opensuse. My experience of Flash at 64 bit on Ubuntu was very stable and choppy free.

I’m running Core 2 Duo Processor with and ATI Radeon and 2 gig of ram.

Did you install ATI drivers?
Are you using desktop effects, and are you kde or gnome


Probably not a good idea to split related help requests or double post in a different help forum, as you did here and over here in 64-bit, although I can understand why you did that. :slight_smile:

I doubt that going to flash 64bit would improve matters. It didn’t for me on a previous 11.x release when I had choppy flash streaming video with 32bit.

What openSUSE release is it?

It’s openSUSE 11.3. I have the ATI drivers installed, well the one that works out of the box. I’m using Gnome and I’m using compiz. This wasn’t an issue on Ubuntu or Fedora.

Ubuntu would install restricted drivers almost by default
Fedora would too if you added the rpmfusion repo

Perhaps you should look at this
openSUSE Graphic Card Practical Theory Guide for Users

I tried different drivers. Thanks but I have gone back to Fedora. It seems to work very well with this laptop. We all have our own distros we prefer.

I have installed the 64 bit version of openSUSE 11.3 I still have choppy flash playback at full screen. I say again, it’s not the hardware it’s perfect in fedora.

So use Fedora.
It’s a great OS.

If you have the graphics driver installed in SUSE, what do you get from a su terminal with:

**/usr/sbin/hwinfo --gfxcard | grep Driver
hwinfo --gfxcard

Too short a release cycle Fedora is. Anyway those commands:

chrispche@linux-o0di:~> /usr/sbin/hwinfo --gfxcard | grep Driver
Driver: “radeon”
Driver Modules: “drm”
Driver Info #0:


hwinfo --gfxcard
24: PCI 105.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
Unique ID: ul7N.xJqnLrXJRG1
Parent ID: vSkL.Ockei9Xj537
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
SysFS BusID: 0000:01:05.0
Hardware Class: graphics card
Model: “ATI Radeon Xpress 1200 (M)”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x7942 “Radeon Xpress 1200 (M)”
SubVendor: pci 0x144d “Samsung Electronics Co Ltd”
SubDevice: pci 0xc511
Driver: “radeon”
Driver Modules: “drm”
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
Memory Range: 0xc0100000-0xc010ffff (rw,non-prefetchable)
I/O Ports: 0x9000-0x9fff (rw)
IRQ: 18 (7706799 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d00007942sv0000144Dsd0000C511bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: radeonhd
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)

Primary display adapter: #24
linux-o0di:/home/chrispche #

By the way if it’s of any use. Flash runs as smooth as a babies bottom when I disable compiz.

By the way if it’s of any use. Flash runs as smooth as a babies bottom when I disable compiz.
This is important.
What about Fedora, do you use Compiz there?
I’m at work at the mo, so can’t look in to this. But there are Compiz gurus here that may help before I get back to you.

Yes I use compiz and flash together with no problems in Fedora. However I want to make openSUSE my main distro. I’m just not used to it yet.

Please check this
Installing and Configuring Compiz
Though Ian deals mainly with KDE.
And there is a link in there to: Compiz Fusion - openSUSE

May offer some help to you

Those links don’t deal with 11.3 though.

I suggest you stick without effects, until someone who uses or is familiar with ATI can help you. I only have nvidia.
Strange one though.

Well I’m happy to disable compiz while I watch flash. It’s not to much bother.

Working on it. The wiki has already been updated to include the one-click installer for 11.3. The guide should still hold true for 11.3 so you can use it for 11.3 even though it’s not specific to 11.3. The one-click still doesn’t include the emerald package so you’ll still have to download that manually. Caf, be looking for some edit requests from me to include 11.3 in my how-to. Currently updating KDE, so once that’s done I’ll see how the installation goes with 11.3.

Take Care,


Keep me updated. I use Gnome, can’t get on with KDE, maybe because I come from a Ubuntu Fedora back ground. Gnome just feels better and less robust.

Now here is a strange thing. If I disable hardware acceleration in flash, playback is smooth at fullscreen. Even with compiz enabled. How does that work???

Why would I click to install compiz. It’s already in the repos.

Thanks Ian, I shall use the one click install. It seems to be a later version than the one I’m using.