Flash is jerking, replay is garbage

I installed 11.3 with KDE on my wife’s computer a couple of months ago, and I am slowly trying to fix the holes in the installation. Things that she “can’t live without”. Now I am working on flash. Youtube and other flash videos in the browser are all jerky, with very poor playback quality as a result. The playback skips forward a couple seconds, then pauses.

This appears to be exactly like a bandwidth issue - but it is not. Bandwidth is fine, and allowing the vid to download completely before playing makes no difference.

I uninstalled all flash stuff, then reinstalled from a standard repo selection that included packman. Pretty much oldcpu’s recommended list of repos. No change.

I’ve spent hours searching and reading threads, trying to find a gold nugget. One said delete ~/.macromedia and ~/.adobe. Did that. No change.

Update everything. No change.
Reboot. No change.

Somebody mentioned he was having a Firefox specific issue with similar symptoms. I try Chrome. No change.

Some ppl seem to connect flash misbehavior with vid driver issues. This box has an ATI onboard gpu - ATI Radeon Xpress 200. So I spend some time looking through some threads I turned up regarding updating that - but this leads me to more searching and no answers. I don’t know how to tell what driver I have installed for ATI, I don’t know how to find the kernel config file to see if ATI has been built in, and more.

And, most of all, I still don’t know what to do to fix this flash business. For all I know, the ATI driver business is a dead end.

Thoughts, suggestions, constructive comments will be appreciated. Some guidance or illumination in this wilderness.

Thank you;

Well your video driver can have an effect as well as your Multimedia setup. I suggest you check out the latter using my bash script file called mmcheck. You can get it here:

MMCHECK - Check Your Multimedia in 10 Steps - Script File, as proposed by RedDwarf

Check out message #69 for version 2.30 of mmcheck.

Thank You,

FWIW My wife’s computer died, I put and older one for her - running oS 11.0/KDE3.5 with a celeron+Xpress 200 onboad graphics running the ATI proprietary (fglrx) driver. Low resolution Flash is viewable but not fluid, like a 24 FPS movie played at 12 FPS. Higher resolution flash videos aren’t even worth mentioning… :frowning:

As you are running KDE 4.x, did you try disabling 3D effects (ALT+SHIFT+F12)?

I have an oldish dell with a turion x2 + xpress 200M onboard. It plays flash with no problems (in 11.0 and 11.4 - I skipped out on 11.3 because 11.2 was truly awful with my video card) with desktop effects enabled or disabled in kde4.

I know its not much help, but I don’t think it is the graphics chip. My suggestion would be to try 11.4 in a live cd. I’m unsure on this but I think the open source ati driver is much improved now (do not use fglrx, it won’t work with newer distro versions). I know it went through a bad patch earlier on but it seems good now.

MMCHECK Is GREAT! It is superb! It just works! I love it, but I already used it, and it fixed other issues, but not this one.

Well - if it is a vid (ATI) driver issue, I am SO in the dark as to where to go. I went to oldcpu’s posts, and there are more warnings and conditionals than I can shake a stick at. I went to the ATI site - they have some “end user” documentation that is supposed to be simple and straightforward - but they lost me by step 3. Unless somebody has an “aha” idea, I guess I will have to break down and spend the time at the keyboard trying to trace the vid biz. Agh, gag me.

Actually, this is a (blessed - :D) good idea. Try the liveCD. OLD advice, but sure. I will do so. I’ve been happy enough because I have 11.2 running wonderfully on another box - one of my main desktop units, so I wasn’t thinking along this line. Doing this is easy, and fairly painless. Not too much time is involved, and a minimal amount of energy expended. Excellent!

Thank you! Even if this does not work, it is worth the try.

Ok - tried it, and oops - flash isn’t installed by default. But, I went to yast and checked it off and installed it, along with 145 other things the installer thought I would now need. Came back an hour or so later when that was all done - and it worked. On some vids I did see the sound/vid timing issue I have seen in another thread, but the herky-jerky was gone and flash was usuable.

Now we get to the truly interesting part. I tell my wife - I’ll fix this tomorrow, today is pretty shot already. I know I’ll need at least a couple, and probably a few, hours getting everything set just right. On my way out, I’ve rebooted her machine, and the update applet tells me “you need updates”. Pull up the detail - guess what, one is for flash. I install the updates. I come back to her machine the next day, and run the browser to one of the vids I was using to check out the flash - soulcollectorsband. It ran.

I kid you not - it just ran. Either it was the update - or the motherboard had a learning curve that the livecd got it through. So, I ain’t touchin’ it to put on 11.4 yet - even though I am now officially curious about LibreOffice - If it ain’t broke, don’t fix it.

Thanks for the thoughts and help.