Flash Installer - Not so flash!!

I am trying to upgrade Flash 9 to 10, by following these instructions Install Adobe Flash Player 10 in openSUSE Linux | SUSE & openSUSE, which are the same as many other sites.
I have deleted 9 and downloaded the “tar.gz” version but when I try to untar the file with tar -zxvf install_flash_player_10_linux.tar.gz the only thing that gets untarred is libflashplayer.so, no new directory, and no flashplayer-installer, which makes the next step a little bit tricky.
It is probably me, so what am I doing wrong?

> It is probably me, so what am I doing wrong?

right or wrong i do not know, but the page you referenced is NOT part
of this community, and it is almost a year old…(stuff moves QUICK)

you can TRY this, which worked for me


Note: Accuracy, completeness, legality, or usefulness of this posting
may be illusive.

I was going to stay out of this thread, but … well, … my curiousity got the better of me.

Why mess around with tarballs (when all it does is provide confusion) when one can simply install an rpm.

A quick look at webpin gives this:
Webpin - search for flash-player

I simply do not understand the fixation on tarball updates. There is a place for them (when there is no rpm available) but this is not such a case.

Please, what am I missing here?

I finished up installing it through the RPM but tried the tar method after a couple of attempts with the RPM failed. Turns out the rpm was doing the right thing, I just neglected the symlink. But all is now well.