Flash freezes Firefox 3.0.1

Although many on the net reported problems with firefox and Flash, I did not have a problem -until now:(.
I have spent hours yesterday and today googling and un-installing, re-installing flash, to no avail.
Adobe has two installers for Linux, a rpm, and a .tar/script.
The rpm version (flash 9) complained that it was already installed although I had uninstalled it with Yast. The script version demands a target dir which I can’t satisfy regardless what I tried.
RE-Installing via YasT did not make the problem go away (although it did install.)
Today I read on CNET that Flash 10 supposedly fixes the Firefox freeze problem. But, again I can’t install it due to the same (or similar) reasons.
Can anyone advise how to install Flash 10 on OpenSuse 11, 32 bit?
Or, any alternative route?
Interestingly enough, if I create a new user on the system, Firefox/Flash behave like in the good old days.

Thank you much.
nat

nat, I don’t think there were ever any “good old days” with Flash. It must have been your imagination :slight_smile:

Maybe it would be helpful if you install directly from the repos instead of using rpms and tars directly. I don’t know if it’ll solve your freeze problem, but the install/uninstall process will go smoother and much faster.

I have 32-bit Flash 9.0 installed from the non-oss repo. It works reasonably well in my x86_64 Firefox using the wrapper.

There seem to be some problems if the site requires both Java and Flash, but I’m not really sure how that works since, e.g., Yahoo News doesn’t tell you anything about the technology that’s required to make their crappy delivery format work.

YouTube works fine though–no crashes or freezes. Apparently no Java required.

I tried uninstalling-installing via the repos with the same problem.

nat

Good news! And this was a hint:

With this you have built some correlation between Java and Flash.
Now, this might sound bizarre (if your sound system is working;)) but since I had fiddled a bit with Java settings, I thought who knows? It might of had an effect even for sites that do not use Java. So:

  1. Using YaST, I UNinstalled Java that came with OpenSuse 11.
  2. Downloaded and installed Sun’s 32 bit Java 1.6.0.7 (actually Java 6 rev 7).
  3. Manually added the symlink in the browser plugin directory:
ln -s /usr/java/jre1.6.0_07/plugin/i386/ns7/libjavaplugin_oji.so
  1. Verified Java was working with Firefox.
  2. Using YaST RE-installed (for the nth time) Adobe Flash from the repos/DVD.
    voila! Flash now works.
    The point is that before going thru this, Flash didn’t work even on sites that had NO Java at all!

Hope someone finds this info useful.
nat

All I needed to do is remove my Java 1_6_0 packages and only keep the java 1_5_0 version. all is working fine here… no more freeze