Flash drive won't mount...

I had my flash drive mounted for the first time on OpenSuse 11.1 since I got it. It worked great, until I tried changing the point mount and remounting. Apparently, taking out the space in “FLASH DRIVE” really screwed it up.

All that I get when I try to mount it is:
mount_point cannot contain the following characters: newline, G_DIR_SEPERATOR (usually /)

Any help?

I don’t quite understand what you have done. Some more questions to help clarify:

  1. How did you change the mount point?

  2. Did you try to relabel a device partition?

Open a console and do

su (to become root, enter root password when prompted)
lshal -m

Now plug the device in, and post the output. You will need to press CTRL-C to terminate. Then cut and paste…

I’m not entirely sure what I did, to be completely honest. I went in and couldn’t find the location of the flash drive using the GNOME Terminal (to use Wine, as in wine /location/program.exe) to open the program (as it is a Windows client). At that point, I went into the Properties for the flash drive by right clicking on it, and saw “Mount Point,” and figured I could take out the space in “FLASH DRIVE” and it would work.

Hope that helps… :\

Sorry for the double post! The previous was literally 7 hours ago, and it won’t let me edit.

Here’s the output:

Start monitoring devicelist:
16:58:13.201: usb_device_58f_6387_53AFA977 added
16:58:13.678: usb_device_58f_6387_53AFA977_if0 added
16:58:13.713: usb_device_58f_6387_53AFA977_if0_scsi_host added
16:58:14.502: usb_device_58f_6387_53AFA977_if0_scsi_host_0 added
16:58:14.516: usb_device_58f_6387_53AFA977_if0_scsi_host_0_scsi_device_lun0 added
16:58:14.869: usb_device_58f_6387_53AFA977_if0_scsi_host_0_scsi_device_lun0_scsi_generic added
16:58:16.489: storage_serial_058f_Flash_Disk_53AFA977_0_0 added
16:58:16.573: storage_serial_058f_Flash_Disk_53AFA977_0_0 property info.interfaces = {'org.freedesktop.Hal.Device.Storage.Removable'} (new)
16:58:19.485: volume_uuid_50BB_0F37 added

It still gives me the mount point error expressed in the first post. Hope this helps even more.

Sounds like you did something like this user (ref thread):

When accessing the properties of a mounted media and changing the mount point option on the “Volume”-Tab, one can set a mount point to use for that volume. It seems that this only referes to the last part of the “real” mount point, so one is expected to enter “foo” when the volume should be mounted on “/media/foo”. This might be better for novice user, but I tried entering “/media/foo”, which was accepted without a problem. Unfortunately when re-plugging the device back in it a warning dialog pops up that says “Cannot mount volume. Unable to mount volume” . When clicking details the message “mount_point cannot contain the following characters: newline, G_DIR_SEPERATOR (usually /)”.

So removing the space is ok, but… I’m guessing you just need to relabel the drive again. Now the commands you use to do this depend on the format used.

After plugging in the USB device, normally you would need to unmount the partition (with umount command). This isn’t a problem for you since it isn’t getting mounted AFAIU.

  1. For vfat, you need to have mtools package installed.

Check the existing label with

mlabel -i /dev/sdb1 -s ::

For example, I have a device with TEST label, so I get:

linux:/home/dean # mlabel -i /dev/sdb1 -s ::
Volume label is TEST

Change the label to ‘FLASH DRIVE’ with

linux:/home/dean # mlabel -i /dev/sdb1 ::‘FLASH DRIVE’
linux:/home/dean # mlabel -i /dev/sdb1 -s ::
Volume label is FLASH DRIVE

  1. For ntfs, you need ntfsprogs package installed.

Check existing label with:

ntfslabel /dev/sdb1

Change label to FLASH DRIVE with

ntfslabel /dev/sdb1 ‘FLASH DRIVE’

Lets see how that goes.

Can you name the equivalent package in native openSUSE 11.1 for changing the drive label? Is it the partitioner in YAST?

@konsultor: I have only outlined the CLI tools for relabeling vfat or ntfs partitions (applicable to all all recent opensuse versions). For ext3 partitions, the e2label command can be used. As well as this, the yast partitioner can be used to relabel your drive. Start the partitioner and click on the relevant device partition, then click ‘Edit’ → ‘Fstab options’. From there you can set volume label.

BTW, check the other thread re your external usb drive.