Flash Drive Troubles

I just don’t understand what I am doing wrong.I have a multi boot environment and I have a good bit of experience with several Linux distros, including this one, yet I cannot create a bootable flash drive for openSUSE 15.2.I installed 42.3 exactly these ways upgraded to 15.1 and attempted to upgrade to 15.2 but I have problems, only shell boot now, so I just decided to reinstall.My MD5, Sha1 and Sha256 for the 15.2 iso are all verified.I have tried Rufus, Image USB and Etcher with the same result every time, it will not boot.I have tried iso write and DD write.An example,I am telling Rufus to create a GPT file system, write DD and boot in UEFI mode just like usual and it still wont boot, secure boot is turned off.It shows my flash drive and attempts to boot but it restarts the PC mid boot.Does anyone have an idea?

I’m not sure that’s a flash drive problem. It sounds more like a hardware incompatibility on the system you are trying to boot.

Perhaps some command line parameters would help. If it is possibly a graphics card issue, try “nomodeset” on the command line.

To get to the boot command line, hit ‘e’ in the boot menu line. Scroll down to the line that starts “linux” (or “linuxefi”).

Rufus is known for not being able to write the hybrid iso image used by openSUSE, I don’t know enough about the other two.
Anyway tested procedures are available here https://en.opensuse.org/SDB:Live_USB_stick
Generally speaking, you have to “dd” copy the iso file to the root of the device, no GPT partitioning or such, just a plain binary copy. Or use SUSE Studio Image Writer if you still have a working openSUSE around.

Thank you both for replying to my difficulty.I appreciate the hint nrickert.Just editing the boot to add “nomodeset” got it to boot.Running Nvidia card and drivers, I am sure that was keeping it from booting correctly.