Flash does not work correctly on openSUSE12.1 32bits (very very Slow)

Hello,
im a new (and happy) user of openSUSE 12.1 32bits (with KDE 4.7 :slight_smile: of course!) and i’m confronted to a embarrasing problem.
I have an AMD6450 pci-express video-card.
I used to play youtube video in full-screen, i make often that in my old Kubuntu (before i switch to openSUSE), and my Xubuntu netbook, but in openSUSE as well with “regular graphics drivers” (these that come with openSUSE), or with ‘fglrx_xpic_SUSE121’ drivers,** i can’t have more 1 or 2 images per seconde when i play any flash video in full-screen**.

  • First i try to check if my flash version was up to date, my firefox version, my google-chrome version, opera, konqueror. All seems to be up to date.
  • After i read a lot in openSUSE forum, and i try one solution there " http://forums.opensuse.org/english/get-technical-help-here/multimedia/468151-flash-hardware-acceleration-opensuse-12-1-a.html " , (with the old version of flash ‘flash-player-10.3.183’ and 2 lines created in ‘/etc/adobe/mms.cfg’), but this solution give my a normal amount of image per second in fulle-screen flash videos but with a systematic crash of my session when i close the fullscreen windows… So i turn back theses settings, and go back to the regular new flash.
  • After i try every combinaison of flash-player, flash-player-kde4, pullin-flash-player, (flash-player-gnome too…), except the 'srcpackage’s.

Nothing can make it work.

Actually there is my configuration :


flash-player, flash-player-kde4, pullin-flash-player Versions:
[SUSE Paste](http://susepaste.org/53738597)


flash plugins installed:
[SUSE Paste](http://susepaste.org/77537303) 
Repository: openSUSE-12.1-Update
Name: flash-player
Version: 11.1.102.62-7.1
Arch: i586
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Information for package fglrx_xpic_SUSE121:
Repository: fglrx
Name: fglrx_xpic_SUSE121
Version: 8.930-1
Arch: i586
Installed: Yes
Status: up-to-date
Repository: openSUSE-12.1-Update
Name: MozillaFirefox
Version: 10.0.2-2.21.1
Arch: i586
Vendor: openSUSE
Installed: Yes
Status: up-to-date

In Benchmark - Flash , i get an average of 12 Frames per second, this seems to be very low, (my netbook with no special driver get 41 FPS in the same conditions)

My /etc/X11/xorg.conf : [SUSE Paste](http://susepaste.org/15698750) 

I am has your listening and has your arrangement for any further information.
Thanks for have read my issue. :shake:
Schrodinger`Cat

PS: i apologize for my english which is not necessarily very good, it is not my native language.

The only thing I do not see in your attempts is boot in safe mode. I improve my flash performance by deleting the “vga=” line at boot time. Safe mode leaves out that parameter automatically. I prefer normal boot but with deleting the “vga=” parameter.

Hi all.
Prexy, thanks for you answer. I see inside my grub options and for the “failsafe” line i have the vga=0c345 activated too :

title Failsafe – openSUSE 12.1 - 3.1.9-1.4
root (hd0,4)
kernel /boot/vmlinuz-3.1.9-1.4-default root=/dev/disk/by-id/ata-WDC_WD1600AAJS-00B4A0_WD-WMAT11674014-part5 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x345
initrd /boot/initrd-3.1.9-1.4-default

My grub config:
SUSE Paste

So i try to take the normal line but i remove vga=0x345 temporaly, for test your answer.
Unfortunatly that make no changes for my problem.

But this morning i have seen a strange things : if i change “System Settings > Destktop effect > advanced > Compositing type” from openGL to Xrender, then flash videos work good !
If i go back to “openGL” it not good.
But KDE4.7 is not very quick in “Xrender”, and i have to switch these option every time i want to play a flash video…
I think its a good start for the answer of this issue…
:slight_smile:

I have the very very very same problem, Maybe its something that got to be with the fglrx driver???