[FIXED] Установка VMware Workstation 7

При установке VMware Workstation 7 требуются Kernel Headers 2.6.31.5-0.1-desktop, у меня с такой версией заголовков нет…Доступно только linux-kernel-headers-2.6.31-3.4, VMWare эту версию принимать не хочет.
Вот вывод установленых пакетов:

alexey@>~$ rpm --query --all '*kernel*'
kernel-pae-devel-2.6.31.8-0.1.1.i586
kernel-default-devel-2.6.31.8-0.1.1.i586
kernel-syms-2.6.31.8-0.1.1.i586
kernel-debug-devel-2.6.31.8-0.1.1.i586
kernel-source-2.6.31.8-0.1.1.noarch
kernel-xen-devel-2.6.31.8-0.1.1.i586
linux-kernel-headers-2.6.31-3.4.noarch
kernel-desktop-devel-2.6.31.8-0.1.1.i586
kernel-desktop-2.6.31.8-0.1.1.i586
alexey@>~$ uname -a
Linux linux-oamt 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

OpenSuse 11.2
Помогите установить, плиз.

приведите полное сообшение об ошибке?

Вот скриншот:

Vmware думает, что у вас ядро версии 2.6.31.5-0.1-desktop, точнее у вас сейчас загружено ядро версии 2.6.31.5-0.1-desktop. Недавно обновляли систему? А обновления ядра там были? Вижу что были, стоит последняя версия из update репозитория. Перезагрузитесь.

Спасибо! Мог бы и сам догадаться… оч. стыдно:shame:

Ни чего постыдного, я сам так же около часа не мог понять в чем дело :slight_smile:

а поддерживает ли Vmware openSUSE 11.2?

А почему нет? У меня исправно работает.

Установил VMware Workstation 7, всё работало пока не обновил систему (не из factory)…

linux-kernel-headers нужно установить.

Установил, но выдаёт тоже сообщение…

Раз раньше работало, должно работать. Может, не дообновилось что-то, как в первом сообщении.

Я так понимаю нужно указать путь к файлу Kernel Headers 2.6.31.12-0.2-desktop. Вот только где он лежит я незнаю :\

Видимо эта версия VMware ещё не понимает этой версии ядра, возможно поймёт в следующей :\