Fixed: suspend on Dell XPS 15

Tumbleweed has worked well on my Dell XPS 9550 (2016 15" laptop), with the exception of suspend to ram which has never worked. Unlike Ubuntu, which worked out of the box, Tumbleweed needs some configuration changes, see below. Also, documentation is hard to come by - when I searched on OpenSUSE suspend issues, I end up on OpenSUSE pages documenting s2ram diagnosis, which was not at all helpful for tumbleweed. Improving the documentation would go a long way to helping users find solutions.

I finally tracked down the suspend handler to tlp, which has a configuration file /etc/default/tlp. I made a few changes, and suspend is now working. I did not confirm exactly which subset of changes is necessary, but here’s what I did:

Set DISK_DEVICES to point to nvme. It came configured as “sda sdb”, neither of which exist on my system. To be clean, I removed the extra values in DISK_APM_LEVEL*, since now there’s only one disk device listed instead of 2. Also blacklisted the dedicated graphics device, as per