"Fix" for nvidia update 470.129.06 => 470.141.03 fails on Leap 15.3

Just a heads up to those who may still be on 15.3 and using nvidia proprietary drivers installed through YaST/zypper.

zypper/YaST cannot resolve dependency to kernel-default-devel = 5.3.18-57 although the appropriate package is available.

It is necessary to manually install:

kernel-default-devel-5.3.18-57.3.x86_64.rpm
kernel-devel-5.3.18-57.3.noarch.rpm

before updating the nvidia driver.

See this bug report: https://bugzilla.opensuse.org/show_bug.cgi?id=1202116

I’m getting a similar message trying to do an update on tumbleweed.

chris@asus-roc:~>$ sudo zypper --pkg-cache-dir /home/chris/zypp/ dup
[sudo] password for root: 
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
7 Problems:
Problem: nothing provides 'kernel-default-devel = 5.18.12-1' needed by the to be installed nvidia-gfxG05-kmp-default-470.141.03_k5.18.12_1-53.4.x86_64
Problem: nothing provides 'kernel-default-devel = 5.18.12-1' needed by the to be installed nvidia-gfxG05-kmp-default-470.141.03_k5.18.12_1-53.4.x86_64
Problem: nothing provides 'kernel-default-devel = 5.18.12-1' needed by the to be installed nvidia-gfxG05-kmp-default-470.141.03_k5.18.12_1-53.4.x86_64
Problem: nothing provides 'kernel-default-devel = 5.18.12-1' needed by the to be installed nvidia-gfxG05-kmp-default-470.141.03_k5.18.12_1-53.4.x86_64
Problem: nothing provides 'kernel-default-devel = 5.18.12-1' needed by the to be installed nvidia-gfxG05-kmp-default-470.141.03_k5.18.12_1-53.4.x86_64
Problem: nothing provides 'kernel-default-devel = 5.18.12-1' needed by the to be installed nvidia-gfxG05-kmp-default-470.141.03_k5.18.12_1-53.4.x86_64
Problem: nothing provides 'kernel-default-devel = 5.18.12-1' needed by the to be installed nvidia-gfxG05-kmp-default-470.141.03_k5.18.12_1-53.4.x86_64

Problem: nothing provides 'kernel-default-devel = 5.18.12-1' needed by the to be installed nvidia-gfxG05-kmp-default-470.141.03_k5.18.12_1-53.4.x86_64
 Solution 1: deinstallation of nvidia-gfxG05-kmp-default-470.129.06_k5.18.11_1-57.1.x86_64
 Solution 2: keep obsolete nvidia-gfxG05-kmp-default-470.129.06_k5.18.11_1-57.1.x86_64
 Solution 3: break nvidia-gfxG05-kmp-default-470.141.03_k5.18.12_1-53.4.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 


Guess I have to wait a bit longer?

Whilst this issue is being addressed I’ve no idea when a fix will be available.

You could download the two required packages:

http://download.opensuse.org/tumbleweed/repo/oss/x86_64/kernel-default-devel-5.18.12-1.1.x86_64.rpm
http://download.opensuse.org/tumbleweed/repo/oss/noarch/kernel-devel-5.18.12-1.1.noarch.rpm

manually install them and then run the nvidia update.

We are already at kernel-default-5.18.15-1.1.x86_64 in Tumbleweed…

That is not the issue. Nvidia requires the two (older) packages listed in post #3 to to fix boo#1201936

See the bug report I initially provided: https://bugzilla.opensuse.org/show_bug.cgi?id=1202116

OK … Humble pie time, I apologise, being mistaken with regard to this issue on Tumbleweed. Please ignore my comments at posts #3 and #5. Sorry for the misinformation and noise.

@kitman

Bug report raised: https://bugzilla.opensuse.org/show_bug.cgi?id=1202192 which you may wish to follow.

Thanks for raising that. This morning’s tumbleweed ‘zypper dup’ is now running.