Fix for Knetworkmanagers hidden SSID issue

Summary of issue: You cannot connect to a wireless network with a hidden ssid, while using knetworkmanager. This leaves you with the choice of using ifup, yast which uses ifup but provides a gui for new users, etc. But thanks to glistwan helpful post there is a simple way to fix this issue, while continuing to use knetworkmanager.

Step 1 Get the wireless name of the hidden network, for example we will be looking for “Tree”.](
Tree is not on the list of course

Step 2 Open the Terminal and enter super user mode.

Lin@Lin1:~> **su**
Lin # iwlist eth1 scanning essid Tree

You should get something like this back

Lin # iwlist eth1 scanning essid Tree
eth1      Scan completed :
          Cell 01 - Address: 00:1D:7E:31:17:29
                    Frequency=2.437 GHz (Channel 6)
                    Quality:5/5  Signal level:-19 dBm  Noise level:-94 dBm
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s

Lin # 

If you get something like this back check your capitalization, spelling, etc. Only an exact match of the name(SSID) will work.

Lin # iwlist eth1 scanning essid tree
eth1      No scan results

Step Three open knetworkmanager click “connect to other network”, you should now see your hidden network.](

After running these steps once you should continue to see and connect to the hidden network.](

Routers tested so far:
Linksys wrt-350n
Cisco 800

If this post works for you please reply and if possible include your OS version number, 32/64bit, Wireless router test, etc.

Thanks. Does this also work with the plasmoid networkmanager applet?

If it continues to connect (you only have to take that “iwlist” action once), then I think it is because the MAC address of the router/AP for the network is recorded in the file where knetworkmanager keeps data for that connection.

I used the other solution, from this thread:
Gave up Knetworkmanager. Made Networkmanager-GNOME work on KDE4!

I am happy that the sollution works for you too. Today I’ve tested the PNM thoroughly with my mobile broadband and wireless. I got some issues. I have recorded system logs and made 30 screenshots of what was going on. I will share this stuff shortly, now I am very busy. But again I am using nm-applet from GNOME in KDE4 and “enjoy” a connection every time i click on the gnomish applet.

Best regards.

Yes, this did work for me. I’m using 11.4 (64 bit) with a broadcom WiFi card and the drivers from packman. It didn’t work without that trick. The router is a Westell 327w, and I am using the plasmoid networkmanager applet in KDE.

I had previously tried the trick of using the gnome nm-applet with KDE (suggested in another thread). And the gnome applet still seems more reliable.

Anyway, I switched back to the KDE applet to keep to a pure KDE system. I can always get by with “ifup” configuration, if the KDE applet stops working for me.

Yes this works with both plasmoid and knetworkmanager.

Best regards,

Tested on Asus K70IO and TP-Link WR541G/542G.

Works perfectly…

Worked for me today in Opensuse 12.1 64bit.

Thank You