Fix available for dhclient not setting default route

The source of the problem that has plagued 11.2 has now been found.
See for details.

There is a patch for /sbin/dhclient-script in the above Bugzilla
thread, but if you are not familiar with the patch utility, you can
modify it yourself. As root, edit /sbin/dhclient-script and change
ALL references to /dev/shm/sysconfig/ to /dev/.sysconfig/network/.
The files were moved!

I’ve been trying it out and it works nicely for me :slight_smile:

How would I use the patch at ?

I would do the manual route, but knowing how to use the patch will add more to my knowledge.

On 12/11/2009 12:56 PM, milomak wrote:
> How would I use the patch at
> ?
> I would do the manual route, but knowing how to use the patch will add
> more to my knowledge.

Copy the patch information to some file, say “patch_dhclient” in your
home directory. After you complete this, open a terminal and enter the

sudo cp /sbin/dhclient-script /sbin/dhclient-script_save
sudo patch -p0 < patch_dhclient

You may have to install the package “patch”. If all goes well, you can
later delete /sbin/dhclient-script_save. If nothing works afterware,
reverse the parameters in the cp statement.

Hi, I also have the problem of connecting to my router but not to internet.
I did change manually as root

replacing all the references to

saved, restarted, deleted my wireless connection on network manager, set it again from scratch and voila!!!

Before this change, I was able to do:
su dhcpcd wlan0 and getting access to internet for some time. Something I remeber as well on 11.1 that made me move to WICD instead of NM. But this change did the trick!

Thanks a lot!!! rotfl!

Opensuse 11.2 (32)

This fix has made the update/11.2-test repo now, if you have been waiting for it you can install it by adding that repo, and selecting the dhclient patch from the list presented.

I added 11.2-test, refreshed zypper, installed dhcp, dhcp-client, dhcpcd. I cleared the manual route I added (/sbin/route), I erased /etc/resolv.conf, and rebooted computer. Upon reboot, /etc/resolv.conf only contained a dozen comments (no “nameserver” line, should have had one). And no default route was on the list (should have had one). Did I miss a step?

(opensuse 11.2 64bit, Intel PRO wireless chip)

You expecting nameserver lines to be set by DHCP server. dhcp-client is the package which includes dhclient. I have this version now :

rpm -qf /sbin/dhclient

Have you selected “dhclient” as the DHCP client in the config file using text editor?

The default client is dhcpcd, so the bug affected people upgrading dhclient systems or who turn it on for particular reasons, not the default install.

You may need to check your Network settings in YaST to, if you had trouble, and set stuff manually, then may be now DHCP interface config, is not set to write the files.

Did you mean /etc/sysconfig/network/dhcp?

Type: string

Default: “”

ServiceRestart: network

Which DHCP client should be used?

If empty, dhcpcd is tried, then dhclient

Other possible values:

dhcpcd (DHCP client daemon)

dhclient (ISC dhclient)


Turn this into “dhclient”? I’m using the default install, so I presume that means I am NOT using dhclient. However, I’m still having issues with /etc/resolv.conf not getting the correct values (it is NOT even being modified at all) and I am not getting a default route (gw) added to my machine. All other GNU or WIN boxes are working just fine (wireless and wired). I’m still having a problem, even though it would appear as though I’m not using dhclient, but the ‘default’ dhcpcd. What should I do?

I had a feeling you weren’t hit by the original issue. I think it unlikely that using dhclient will help.

If you are using DHCP, then it should set IP address, default route, optionally hostname and the name servers. Does configuring network statically work? Check the log files when it starts to see if you obtain response from DHCP server.

Probably better to start a new thread, if you don’t solve it yourself access to DHCP server.