fish/sshd fails to a new 12.1 box

My main box was running 11.4
I did a new install of 12.1
Put back the ssh config files from the previous install and set up ssh, which includes password authentication.

Typically I use fish or sshd from my remote machines (I only use ssh over the LAN)

Now sshd or fish both fail, but here is the curve ball. If I use a terminal to ssh, it works.

I have the feedback on the failed sshd attempt from /var/log/messages

Nov 21 05:27:16 xxxx-121 sshd[10524]: error: PAM: Authentication failure for xxxx from 192.168.0.6
Nov 21 05:27:16 xxxx-121 sshd[10526]: error: PAM: Authentication failure for xxxx from 192.168.0.6
Nov 21 05:27:16 xxxx-121 sshd[10524]: Accepted password for xxxx from 192.168.0.6 port 53203 ssh2
Nov 21 05:27:16 xxxx-121 systemd-logind[870]: New session 7 of user xxxx.
Nov 21 05:27:16 xxxx-121 sshd[10526]: Accepted password for xxxx from 192.168.0.6 port 53204 ssh2
Nov 21 05:27:16 xxxx-121 systemd-logind[870]: New session 8 of user xxxx.
Nov 21 05:27:16 xxxx-121 sshd[10533]: subsystem request for sftp by user xxxx
Nov 21 05:27:16 xxxx-121 sshd[10534]: subsystem request for sftp by user xxxx
Nov 21 05:27:16 xxxx-121 systemd-logind[870]: Removed session 8.
Nov 21 05:27:16 xxxx-121 systemd-logind[870]: Removed session 7.
Nov 21 05:27:16 xxxx-121 sshd[10590]: error: PAM: Authentication failure for xxxx from 192.168.0.6
Nov 21 05:27:16 xxxx-121 sshd[10590]: error: PAM: Authentication failure for xxxx from 192.168.0.6
Nov 21 05:27:16 xxxx-121 sshd[10590]: Failed password for xxxx from 192.168.0.6 port 53205 ssh2
Nov 21 05:27:16 xxxx-121 sshd[10590]: error: PAM: Authentication failure for xxxx from 192.168.0.6
Nov 21 05:27:16 xxxx-121 sshd[10590]: Failed keyboard-interactive/pam for xxxx from 192.168.0.6 port 53205 ssh2
Nov 21 05:27:16 xxxx-121 sshd[10590]: Failed password for xxxx from 192.168.0.6 port 53205 ssh2

That might be the problem, though the log message are not very useful.

The location of sftp changed from /usr/lib64/ssh to /usr/lib/ssh

Check sshd_config, and make sure it uses “lib” not “lib64”.

That was it

That you so much!