Fish inside konqueror stopped working

Dear all,
I am using for quite some time fish protocol inside konqueror and everything worked great. In the last two days after I type fish://username@host the login prompt appears (as always) but nothing happens, after I give credentials and press ok.

Everything stays the same (only the k at the upper right part of the screen is rotating). I am running kde 4.7.2

I am trying to find a way to debug that but I do not know how.

ltrace konqueror brings nothing. Nothing also at /var/log/messages.

I need your ideas on how to debug that. Where to search for error messages, how to see what it might be causing that.

Any ideas?
Alex

I found this one through strace konqueror 2> debug.txt


write(16, "    1f_45_\0\0\0\33fish://bbb@host"..., 41) = 41
read(6, 0x649ee4, 4096)                 = -1 EAGAIN (Resource temporarily unavailable)


and google brings weird results

Regards
Alex

First: search the forums for “fish”, IIRC this looks like a regression.
Second: check the server side for messages, again IIRC this issue is authentication related.

These two links seem to be more appropriate

https://bugs.kde.org/show_bug.cgi?format=multiple&id=77866

#435337 - KIO slave fish:// doesn’t work on debian amd64 kernels 2.6.21 and above - Debian Bug report logs](http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=435337)

with people having similar problem with me. Unfortunately none did work so far.

Regards
Alex

Your kde version is so far back
Most folk are way ahead, I do seem to recall some issues back then and IIRC I was able to use sftp
But ATM fish is fine for me

Hm… probably then is time to move to 12.2… right?

Alex

I am udpdating to 12.2 already :slight_smile:
could you please remind me the ‘suggested’ repos for a system (including packman)?

Regards
Alex

Darn!
I am hit!

https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/479770-grub-problem-after-upgrade-opensuse-12-2-a-2.html#post2518288

https://forums.opensuse.org/content/128-re-install-grub2-dvd-rescue.html

https://forums.opensuse.org/content/127-multimedia-restricted-formats-installation-guide-12-2.html

any pills also to prescribe?

Not without a proper consultation
Symptoms…?

Hi, there
I fixed that!!! Actually I boot with opensuse 12.2 dvd and it looks like it repaired everything. Great news! All things look fully functional now.

Except that fish does not work yet.

I launched konqueror with

konqueror 2 > test

Kde version is 4.8.4 Release 2

and inside test I searched for error messages. Please find below some of those



,,,,
access("/home/aaa/.kde4/share/config/kio_fishrc", W_OK) = -1 ENOENT (No such file or directory)
access("/home/aaa/.kde4/share/config/kio_fishrc", F_OK) = -1 ENOENT (No such file or directory)
access("/home/aaa/.kde4/share/config", W_OK) = 0
stat("/home/aaa/.kde4/share/config/kio_fishrc", 0x7fff3adf6b90) = -1 ENOENT (No such file or directory)
stat("/usr/share/kde4/config/kio_fishrc", 0x7fff3adf6b90) = -1 ENOENT (No such file or directory)
stat("/etc/kde4/share/config/kio_fishrc", 0x7fff3adf6b90) = -1 ENOENT (No such file or directory)
recvfrom(6, 0x1c9f574, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)

,,,

what will the doctor prescribe now?

Alex

Did you try
sftp://

That is what konqueror returns


The requested operation could not be completed

Connection to Server Closed Unexpectedly

Details of the Request:

URL: sftp://hidden@hidden
Protocol: sftp
Date and Time: Wednesday 16 January 2013 08:24
Additional Information: The host key for this server was not found, but another type of key exists. An attacker might change the default server key to confuse your client into thinking the key does not exist. Please contact your system administrator.
Description:

Although a connection was established to hidden, the connection was closed at an unexpected point in the communication.


I guess that can be fixed but still wonder why fish is dead. Has it been stopped to be programmed and now is considered as obsolete?

Alex

The key question is. Does your fish work or you never tried it?
Alex

Mine… Yes but my kde is 4.9.5

I might try to update but I doubt this will help… :frowning:

I do not think that the updating will fix this type of error message (as also posted before)


access("/home/aaa/.kde4/share/config/kio_fishrc", W_OK) = -1 ENOENT (No such file or

Have you tried a new user account on the remote machine?
or remove all files from .ssh in your current user

But I can tell you I’m 100% sure there were stages in kde4 where fish and even sftp didn’t work - I just can’t say when exactly…