fish broken with latest updates

I regularily connect to hosts with fish://<url> After the updates a few days ago, suddenly I cannot use fish to connect with the message - ‘Connection to host testhost1 is broken.’… I dont see any other errors reported in /var/log/messages, so I dont know what to report other than the error text…

OS: Linux 2.6.27.21-0.1-pae i686
System: openSUSE 11.1 (i586)
KDE: 4.2.86 (KDE 4.2.86 (KDE 4.3 >= 20090514)) “release 125”

It’s working for me. Are you using it in Dolphin (I am)
But also use kssh (kde3 version from community)

First try ssh from the command line and see that ssh is not broken. fish uses ssh internally.

yeah ssh works fine via the command line. I typically use fish in krusader, and I verified it also fails in dolphin and konqueror… One thing just occured to me - I did recently rename my ~/.kde4 folder and restart kde4 to get things reset after some issues with plasma… could there be something out of sync? I poked around the old .kde4 folder to see if anything looked suspicious… but I mostly just saw application configs…

When I tried fish from Konqueror just now, I too get an error. But, when I re-tried, it got connected.

To my knowledge, .kde4 does not store ssh authentication details. However, it keeps URL history including fish:// URLs.

I have the exact same problem, ‘fish’ protocol simply stopped working after upgrading to KDE 4.3. Well, it’s still in beta so things like this are to be expected. As a (hopefully) temporary workaround, I use the KDE3 Konqueror for the ‘fish’ connections. Otherwise, plain ‘ssh’ works just fine.

Me too. Upgraded today, KDE terrific, but fish broken.

Same thing.
opensuse 11.1 kernel 2.6.27.21
kde from 4.2.85 to 4.2.87 - fish:// won’t work (even on fresh account)
Disconnecting me immediately when trying to connect.
ssh works well.

Did you try sftp://URL …? IMHO it is superior to fish. It works for me, but I’m not running KDE4.

Interesting.

I can’t test sftp today, but, in general, it would be interesting to know differences (pros and cons) of the two “protocols”.

Bye.

sftp:// works!
Big thanks!

also don’t know the difference between two protocols but sftp:// better just because it works now <:)

Using fish with konqueror/dolphin/mc under factory (milestone 1 + latest updates) with KDE 4.3 works fine here (x86_64).

The sftp suggestion does work which is a nice workaround… I am running the factory updates but I still get the ‘Connection to host <host> is broken’ dialog:

OS: Linux 2.6.27.21-0.1-pae i686
System: openSUSE 11.1 (i586)
KDE: 4.2.86 (KDE 4.2.86 (KDE 4.3 >= 20090514)) “release 126”

I too am a little confused about the difference between fish:// and sftp:// Can anyone elighten me?

Thanks

I discovered a nice benefit by using sftp instead of fish… I had noticed if I saved a session in Kate when editing files from a fish connection, the session would not load later if I fired up Kate and selected the session from the dropdown. Later I figured out I could establish a separate fish connection with the remote host, and Kate did better in loading the session. but, I saved a session where I was editing 5 files in sftp… and later I had to re-visit the files, and loading the session from a cold start worked just great… sweeeeeet… :slight_smile:

I am not sure when the patch moved in, but fish appears to be fixed and functioning nicely :slight_smile:

Life is gooooood!

That it is. Has been for some time.