First time Linux user. Can't find my GUI ?


I didn’t want do do all the downloading, so I bought a DVD from Cheap Bytes. (openSUSE 11)

The installation went well, but after the install, it boots into the shell command prompt, and I have yet to figure out how to launch KDE.

I chose KDE 3 during install.

How do I get KDE to launch ?

See if this helps:
SDB:Black screen after boot - openSUSE

If you log in at the command line and run startx, what happens?

When I entered startx, it gave me a string of text including:

this is a pre-release version of x server

x server

data incomplete in file /etc/x11/xorg.conf

at least one device section required

I don’t think its a problem with the graphics card, because I had graphics and mouse function during install.

which graphics card do u have?


“root” in console and enter admin password

then type “sax 2” and reconfigre display

I think you mean “sax2” and not “sax 2”. To my understanding, there is no space between ‘sax’ and ‘2’.

sorry, my mistake :frowning:

I re-booted and chose safe mode, and it booted into a GUI, I’m not sure if its X or KDE.

I tried using the sax2 command when it prompted me with a little window, but nothing happened.

So I went into YAST and looked at the graphics hardware, and it showed the card correctly as a GeForce 8500.

It also listed the mainboard integrated graphics chip, which I’m not using.

It listed the monitor as generic. (It’s a Hitachi 802+ 21" CRT)

Hi, in order to use sax2 do this, boot into normal mode and see if a desktop environment starts, if not then press “CTRL+ALT+F1” and u will reach a console:

type “root” enter password

now type in “sax2 -m 0=nv” or “sax2”

if it says xserver already running and doesn’t do anything then type in

“init 3”

then “sax2”

once configured type in “init 5” to reach a desktop and it should work.

If it works then press “CTRL+ALT+F1” to reach a console again and type “exit” to logout as root and press “CTRL+ALT+F7” to reach a gui again.

This kinda makes it sound to me like maybe something got horked during the install? Most newer version of Linux including this one send you straight into the GUI without making you mess with the command line.
Maybe just trying the install again might make a difference? :confused:

I did reboot in normal mode and all I get is a command promt.

startx fails.

I’m considering doing a second install, but I don’t know if I need to format the hard drive first.

I don’t have time to deal with it right now, gonna have to wait till later.

You will have to reinstall then r u sure your dvd or cd is fine? Its best to format the drive, that can be done during installation.

The odd thing is, the YAST screens displayed perfectly during install, and the graphical screen during boot up displays perfectly.

The mouse worked correctly, and install seemed to go great.

It seems like the graphics card is working. It just wont launch the GUI. No startx.

I am confused as well :confused:

this isn’t normal behaviour… did u try everything the people here told u to though?

this isn’t normal behaviour… did u try everything the people here told u to though?

I tried to try everything that they told me to try :slight_smile:

if after reinstalling u still have a problem then we will have to hunt down the problem and destroy it :smiley:

After we destroy it, will there be bits of binary all over everywhere? :smiley:

we can send the broken code to Microsoft so they can add it to Windows 7 :stuck_out_tongue:

reading the posts, it appears that you have 2 graphics devices ? correct ? one on-board & the other an add-in pci/pci-e ? if so, try going in to your bios & disabling the on-board. then, at the boot screen,type init 3 on the boot options line & press enter. once you get to a log-in prompt,log-in as normal,then, su to root. once there, type sax2 & press enter. then configure your graphics device


ok, I’ll try that, but it will be a while.