First Impressions after Installation of openSUSE 11.0

I’m using Linux as my main OS for several years now and (open)SuSE every now and then since the 7.0 release. Though I see that people with critical annotations get shouted down by “real” enthusiasts oftentimes (see soapbox section pp.) I have the impression that 11.0 is much more premature than earlier major releases and guess it’s o.k. to say so.

During the installation (on sdb) a ntfs partition with Win XP (sda1) was recognized as a partition with an “unknown filesystem” so - consistently - there isn’t any entry in GRUBs menu.lst for Win XP :frowning: An empty fat32 partition (dedicated for common data storage) gets listed as “Other Linux” :confused: (never experienced something like this before with any distribution I installed or tried as I live-version).

With kde4 (not really stable yet, I know) I get messages every 2 or 3 seconds that knotify had crashed (different explanations each (!) time). Right now there are about 20 message windows open. With kde3 (pretty stabe yet, I know) I get these messages every 20 seconds - wow! Maybe due to the frequent error messages display freezes again and again. Desktop effects don’t work at all. Trying to activate them really often leads to black screens. Pretty poor.

My system (desktop) is about 1 1/2 years old (nVidia graphics card 8600 gs, 2 GB RAM) and therefore pretty easy to handle for almost any contemporary Linux distribution (exept openSuSE 11) - bummer!

Funny - I installed 11.0 on two machines yesterday, a QC Xeon + AMD 64 4800+, both of them installed cleanly, without any issues and the only things I had to do was 1-click nVidia drivers, 1-click MP3 support and have a stab at the X-FI drivers (but that’s Creatives fault and not SuSE) and I was rolling butter smooth on both machines.

I think it’s OK to say this has been the best SuSE in the recent years.

That needn’t be contracitory! :wink:

I haven’t had any issues with openSUSE 11 either, kde 3.5.9 works perfectly when I tried it, I have some problems with gnome and pulseaudio but then again all the distros with pulseaudio I try give me problems.

Otherwise its been very stable for me aside the fact that kde 4 has many bugs still, but thats it.


i want to post some of my first impressions:
The new installer is amazing and was working for me as it should

then some problems arrived. i decided kd4 as desktop because i want to see how it works. The first impression was that all fonts were fuzzy. I played around and found out that the antialiasing effect of kde4 caused this. After I set the hinting style to “complete” all fonts were good and readable.

The next step was to install the nvidia driver from the nvidia repositories. it worked well so far except for that I now had only 60 Hz refresh rate :eek: (have a CRT monitor). Then I found out that the “Modline” in xorg.conf was missing. I added the one I used in 10.3 (with the same monitor) and got back 100 Hz :smiley:

For now I am happy with kde4. ok sometimes it seems not to be as stable as kde3 but for my purposes it is still usable and I like the desktop effects and it’s easy configuration :smiley:

Sadly disappointing :frowning:

I never had any problems with 10.3.

So far:

  1. Permanent error (with ALL versions of KDE4) on each login, nobody seems to know why either.

  2. Network manager icon changes to that green globe thing on logout/logbackin.

  3. Plasma crashes when I plug in my USB (reiser encrypted) drive.

  4. Dolphin has no “media” shortcut anymore, it’s NOT the same simply making a link to /media.

  5. “popping” sound from my speakers, mostly when running on battery.

  6. No laptop keys work, ie no mute/volume etc’.

  7. The tray icons get corrupted sometimes.

But on the upside:

  1. I can now use “fwcutter” and the associated driver files for my Broadcom 4312, and it starts perfectly on each boot.

  2. Dolphin finally has a “delete” function, and the “terminal” thing is handy.

openSUSE 11, all updates (as of today), KDE4, HP dv6645 laptop, 2 gigs, AMD Turion, Nvidia 8400gs m (using the repo drivers as installed automatically by the update tool).

besides every update is improving kde 4 on 11, I was unable to eject my dvd using the recently plugged devices widget and now today I can, updates r coming in very quickly

Looks like every single problem on the list is due to KDE4 - please switch to KDE3.5 and let’s see how that 11.0 treats you :wink:

i get the knotify problem too! although not as often as you, quite why i don’t know, as, like you said, the error messages are different each time. maybe a bug? but i can’t really report it since i don’t know what causes it…

I have played with OpenSuSe 11 64 bit since b3 using the Live Gnome CD. Today I installed the DVD as a clean install, using the Gnome desktop.
The only thing I do to “cheat” a little in enabling browser plugins is to download Firefox and unzip it to my home folder, then paste in all the plug ins I need, Java, Flash, mplayer. Through all the beta’s and release candidates I just could not get the Java plugins to work, all other plugins were fine, but Java was no go.
Firefox runs fine, there’s no discernible loss of performance / speed or anything so it makes no difference to me. Oh yes, to improve the fonts in Firefox I copy the firefox-openSUSE.js file out of the default firefox installation folder to my own in /home/peterm/firefox/defaults/pref
I use the 64 bit version because my vmware machines are much faster on a 64 bit system than on a 32 bit system. I use vm’s extensively for testing and study and often have a team of 4 servers and a desktop running.
Everything works, I am impressed. :slight_smile: Great work guys and gals.
Regards Peter.

I have had a good experience with the kde 3 installation. I tried kde4 earlier - but that is still problematical (or maybe I don’t know how to do things)
Opensuse 11 is very professional and has some nice new features

First, many thanks to all those who worked on this version of openSUSE.

I did an “upgrade” install from 10.3 from a downloaded DVD.
The install went smoothly, except…
Received a couple of hundred (literally!) dependency problems.
These seemed to be mostly regarding KDE 4.
I selected a lot of "ignore"s and ended up with KDE 3.5 (again).

The new Firefox 3.0 is lightening fast.

My biggest concern is that Auto-update is broken.
The good news: it knows it is broken and gives the message -

Unable to check for patches and updates because /usr/sbin/zypp-checkpatches-wrapper helper programm is not set SUID root. This problem might be solved by setting “File Permissons” in YaST “Local Security” tab to “easy” or by modifying /etc/permissions.local
WARNING: Since zypper 0.11.1, this program is deprecated and will be dropped for openSUSE 11.1. Use zypp-refresh-wrapper as a replacement, followed by any regular zypper query command. To check for patches, execute ‘zypper --xmlout lu’ after executing zypp-refresh-wrapper.

The bad news: it is broken.
The good news: I can check for updates in Yast manually.
The bad news: I miss the automatical updater.
It worked nicely in 10.3.

Last item - my mouse wheel is still “broken”.
It worked on 10.2, got broken in 10.3 and is still broken.
Sure do wish someone would fix this or tell me how to fix it myself.

I give version 11.0 an 8/10. :o

I haven’t had any issues with openSUSE 11 either, kde 3.5.9.
Just a few tweaks and should be good to go. It was pretty painless.
I think I am going to like 11.0 a lot.

I switched to KDE4.1 beta today, and most of my problems vanished :D.

No more error on login, and the applet thingies work properly.

Nice themes too :D.

Now to figure out why I can’t get visudo to let me use nopasswords!

first post! :smiley:

best opensuse install so far (inspiron6400 core duo (i386x2)).

all worked except wireless on broadcom 1390 mini pci. i made my own howto about a year ago on opensuse10.2 and it still works with ndiswrapper. always takes around 20min to get working, but to be fair, its not opensuse’s fault, broadcom don’t make their drivers opensource . :confused:

(my better half has a amd x64, and same howto is used with x64 drivers)

everything works now, but i have no time for “closed source” software or drivers anymore. broadcom, u suck! :mad:
*(i order an intel wifi card and will avoid all broadcom products from now on.)

i also went for kde3.5, as its faster and strains the gpu less than kde4. i found that battery life and temp is much more acceptable with kde3.5. also very stable.
i would use kde4 on a desktop, not a laptop.

i also installed xfce on my server. very nice. clean and fast. perfect for server. :cool:

i been on suse since 9.3, and every release was a major improvement. opensuse 11 is by far the best os today for me. looks great, very stable and secure. never let me down. i hated the old package manager, but the new one is a 10/10.

great work opensuse team!

Just to note that not all probs with 11.0 stem from KDE4: my first
attempt with the 11.0 retail dual-layer DVD from the box on an Athlon64
didn’t go too well, either, and I had selected the Gnome desktop just to
avoid the KDE3 vs. KDE4 issues. :wink:

After going through the software selection and adding and removing a few
(ok, a lot of) packages, it just hung with the progress bar frozen at 27%.

Tilman Schmidt
Phoenix Software GmbH
Adolf-Hombitzer-Str. 12 Amtsgericht Bonn HRB 2934
53227 Bonn, Germany Geschäftsführer: W. Grießl