First boot fails after installing 13.1 32-bit KDE Thinkpad T23 - graphics problem

I did a full installation of 13.1 32-bit KDE on a Thinkpad T23 using the DVD. This replaced 12.3, formatting both / and /home. The installation proceeded fine, but the system locks on the initial and subsequent boots, either normal or recovery. The system will boot into runlevel 3. The boot log is

resume device  not found (ignoring)
Waiting for device /dev/root to appear:  ok
fsck from util-linux 2.23.2
[/sbin/fsck.ext4 (1) -- /] fsck.ext4 -a /dev/sda5 
root: clean, 131018/1114112 files, 1103811/4456448 blocks
fsck succeeded. Mounting root device read-write.
Mounting root /dev/root
mount -o rw,acl,user_xattr -t ext4 /dev/root /root

Welcome to [0;32mopenSUSE 13.1 (Bottle) (i586)[0m!

         Starting Collect Read-Ahead Data...
         Starting Replay Read-Ahead Data...
[[32m  OK  [0m] Listening on Syslog Socket.
[32m  OK  [0m] Reached target Remote File Systems (Pre).
[32m  OK  [0m] Reached target Remote File Systems.
[32m  OK  [0m] Listening on Delayed Shutdown Socket.
[32m  OK  [0m] Listening on /dev/initctl Compatibility Named Pipe.
[32m  OK  [0m] Set up automount Arbitrary Executable File Formats File System Automount Point.
[32m  OK  [0m] Listening on Journal Socket.
         Starting LSB: Set default boot entry if called...
         Starting Create list of required static device nodes for the current kernel...
         Mounting Huge Pages File System...
         Mounting Debug File System...
         Starting Create dynamic rule for /dev/root link...
         Starting Journal Service...
[32m  OK  [0m] Started Journal Service.
         Mounting POSIX Message Queue File System...
         Expecting device dev-disk-by\x2did-ata\x2dINTEL_SSDSA1M080G2HP_CVPO012500QB080EGN\x2dpart7.device...
[32m  OK  [0m] Listening on udev Kernel Socket.
[32m  OK  [0m] Listening on udev Control Socket.
         Expecting device dev-disk-by\x2did-ata\x2dINTEL_SSDSA1M080G2HP_CVPO012500QB080EGN\x2dpart6.device...
         Expecting device dev-disk-by\x2did-ata\x2dINTEL_SSDSA1M080G2HP_CVPO012500QB080EGN\x2dpart1.device...
         Expecting device dev-disk-by\x2did-ata\x2dINTEL_SSDSA1M080G2HP_CVPO012500QB080EGN\x2dpart3.device...
         Expecting device dev-disk-by\x2did-ata\x2dINTEL_SSDSA1M080G2HP_CVPO012500QB080EGN\x2dpart2.device...
[32m  OK  [0m] Created slice Root Slice.
[32m  OK  [0m] Created slice User and Session Slice.
[32m  OK  [0m] Created slice System Slice.
[32m  OK  [0m] Created slice system-getty.slice.
[32m  OK  [0m] Reached target Slices.
[32m  OK  [0m] Started Collect Read-Ahead Data.
[32m  OK  [0m] Started Replay Read-Ahead Data.
[32m  OK  [0m] Started LSB: Set default boot entry if called.
[32m  OK  [0m] Mounted Huge Pages File System.
[32m  OK  [0m] Mounted Debug File System.
[32m  OK  [0m] Started Create dynamic rule for /dev/root link.
[32m  OK  [0m] Mounted POSIX Message Queue File System.
[32m  OK  [0m] Started Create list of required static device nodes for the current kernel.
         Starting Create static device nodes in /dev...
         Starting Load Kernel Modules...
         Starting Setup Virtual Console...
         Starting Remount Root and Kernel File Systems...
%G[32m  OK  [0m] Started Create static device nodes in /dev.
(K[32m  OK  [0m] Started Load Kernel Modules.
[32m  OK  [0m] Started Remount Root and Kernel File Systems.
         Starting Load/Save Random Seed...
         Starting Apply Kernel Variables...
         Starting udev Kernel Device Manager...
[32m  OK  [0m] Reached target Local File Systems (Pre).
         Mounting Lock Directory...
         Mounting Runtime Directory...
[32m  OK  [0m] Mounted Lock Directory.
[32m  OK  [0m] Started udev Kernel Device Manager.
[32m  OK  [0m] Started Load/Save Random Seed.
[32m  OK  [0m] Started Apply Kernel Variables.
[32m  OK  [0m] Mounted Runtime Directory.
[32m  OK  [0m] Started Setup Virtual Console.
         Starting udev Coldplug all Devices...
[32m  OK  [0m] Started udev Coldplug all Devices.
         Starting udev Wait for Complete Device Initialization...
         Starting Show Plymouth Boot Screen...
[32m  OK  [0m] Found device INTEL_SSDSA1M080G2HP.
         Mounting /windows/Storage...
[32m  OK  [0m] Found device INTEL_SSDSA1M080G2HP.
         Mounting /windows/XP...
[32m  OK  [0m] Found device INTEL_SSDSA1M080G2HP.
         Mounting /windows/98SE...
[32m  OK  [0m] Found device INTEL_SSDSA1M080G2HP.
         Activating swap /dev/disk/by-id/ata-INTEL_SSDSA1M080G2HP_CVPO012500QB080EGN-part7...
[32m  OK  [0m] Mounted /windows/98SE.
[32m  OK  [0m] Mounted /windows/Storage.
[32m  OK  [0m] Activated swap /dev/disk/by-id/ata-INTEL_SSDSA1M080G2HP_CVPO012500QB080EGN-part7.
[32m  OK  [0m] Reached target Swap.
[32m  OK  [0m] Found device INTEL_SSDSA1M080G2HP.
         Starting File System Check on /dev/disk/by-id/ata-INTEL_SSDSA1M080G2HP_CVPO012500QB080EGN-part6...
[32m  OK  [0m] Reached target Sound Card.
[32m  OK  [0m] Mounted /windows/XP.
systemd-fsck[379]: home: clean, 12/327680 files, 55966/1310464 blocks
[32m  OK  [0m] Started File System Check on /dev/disk/by-id/ata-INTEL_SSDSA1M080G2HP_CVPO012500QB080EGN-part6.
[32m  OK  [0m] Started udev Wait for Complete Device Initialization.
         Starting Activation of LVM2 logical volumes...
         Mounting /home...
         Mounting FUSE Control File System...
[32m  OK  [0m] Mounted /home.
[32m  OK  [0m] Started Activation of LVM2 logical volumes.
[32m  OK  [0m] Mounted FUSE Control File System.
[32m  OK  [0m] Reached target Encrypted Volumes.
         Starting Activation of LVM2 logical volumes...
[32m  OK  [0m] Started Activation of LVM2 logical volumes.
[32m  OK  [0m] Reached target Local File Systems.
         Starting Tell Plymouth To Write Out Runtime Data...
         Starting Recreate Volatile Files and Directories...
         Starting Trigger Flushing of Journal to Persistent Storage...
[32m  OK  [0m] Started Recreate Volatile Files and Directories.
         Starting LSB: AppArmor initialization...
         Starting Update UTMP about System Reboot/Shutdown...
[32m  OK  [0m] Started Trigger Flushing of Journal to Persistent Storage.
[32m  OK  [0m] Started Update UTMP about System Reboot/Shutdown.
[32m  OK  [0m] Started LSB: AppArmor initialization.
[32m  OK  [0m] Started Show Plymouth Boot Screen.
[32m  OK  [0m] Started Tell Plymouth To Write Out Runtime Data.
[32m  OK  [0m] Reached target System Initialization.
[32m  OK  [0m] Listening on CUPS Printing Service Sockets.
[32m  OK  [0m] Listening on Avahi mDNS/DNS-SD Stack Activation Socket.
[32m  OK  [0m] Listening on PC/SC Smart Card Daemon Activation Socket.
[32m  OK  [0m] Reached target Timers.
         Starting Restore Sound Card State...
[32m  OK  [0m] Reached target Paths.
[32m  OK  [0m] Listening on D-Bus System Message Bus Socket.
[32m  OK  [0m] Reached target Sockets.
[32m  OK  [0m] Reached target Basic System.
         Starting Avahi mDNS/DNS-SD Stack...
         Starting YaST2 Second Stage...
         Starting System Logging Service...
         Starting Name Service Cache Daemon...
[32m  OK  [0m] Started Name Service Cache Daemon.
         Starting WPA Supplicant daemon...
         Starting Modem Manager...
         Starting Permit User Sessions...
         Starting D-Bus System Message Bus...
[32m  OK  [0m] Started D-Bus System Message Bus.
         Starting Login Service...
[32m  OK  [0m] Started Restore Sound Card State.
[32m  OK  [0m] Started Permit User Sessions.
[32m  OK  [0m] Started System Logging Service.
         Starting Authorization Manager...
[32m  OK  [0m] Started Avahi mDNS/DNS-SD Stack.
[32m  OK  [0m] Started WPA Supplicant daemon.
[32m  OK  [0m] Started Login Service.
[32m  OK  [0m] Started Authorization Manager.
[32m  OK  [0m] Started Modem Manager.

After the boot messages get to “Started Modem Manager.”, the screen goes to low contrast with a green tint. The system is locked, and I have to hold the power button to reboot.

This is no doubt a graphics problem. This T23 has S3 SuperSavage graphics. They were a problem in 12.3, but there is a workaround described in The bug report mentions that the fix would be included in 13.1. If it is, something else is wrong. the graphics are

24: PCI(AGP) 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.319]
  Unique ID: VCu0.jjzIPZ_Zra1
  Parent ID: vSkL.7ikikoAJ7O0
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "IBM ThinkPad T23"
  Vendor: pci 0x5333 "S3 Inc."
  Device: pci 0x8c2e "SuperSavage/IXC 64 SDR"
  SubVendor: pci 0x1014 "IBM"
  SubDevice: pci 0x01fc "ThinkPad T23"
  Revision: 0x05
  Memory Range: 0xc0100000-0xc017ffff (rw,non-prefetchable)
  Memory Range: 0xe8000000-0xebffffff (ro,non-prefetchable)
  Memory Range: 0xe4000000-0xe7ffffff (ro,non-prefetchable)
  Memory Range: 0xe0000000-0xe1ffffff (ro,non-prefetchable)
  Memory Range: 0xe2000000-0xe200ffff (ro,non-prefetchable,disabled)
  IRQ: 11 (772 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00005333d00008C2Esv00001014sd000001FCbc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: savage
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)

I tried the workaround mentioned in the bug report, but that made no difference.

Any ideas what to try next?

The Xorg.0.log file is at SUSE Paste


Same problem to me with 2 different T23 :frowning:


I made a bug report at

No resolution yet.


This issue got kicked around more in the Hardware section, in thread

wolfi323 identified a workaround to get booted into graphics mode, and it is described in the other thread. Implementing the fix requires editing or creating a file in the /etc/X11/xorg.conf.d directory.

You can do that by booting into runlevel 3 and using a text editor like vi, or booting into a live Linux session and editing it. I tried booting Knoppix 7.2.0, but it failed on my T23, probably the same graphics driver bug. The Parted Magic version of 13Aug2013 did boot my T23, and let me edit files. My T23 dual-boots Windows XP, and I also used that with an application to access ext4 partitions and could edit the file. However, the write access via Windows was sometimes incorrect and fsck deleted the files at the start of boot.

Now to see if the bug gets fixed in the savage driver.


wolfi323 found that there is a fixed savage driver. See and following for discussion. It worked on my T23, particularly after disabling acceleration.

By adding the X11:XOrg repository at during the first few steps of installation, and selecting its versions for installation, one should be able to have a working system on the first boot.