first attempt to upgrade to leap 15.0 but 15.0 live KDE doesnt works

On my son’s laptop, an asus vivobook pro N552VW-FY204T, i7 6700HQ Processor, 16Gb RAM, graphic intel HD Graphics & NVIDIA GeForce GTX 960M with 2G/4G GDDR5 VRAM (I suppose that intel HD is used, becouse I unstalled bumblebee that worked badly), running leap 42.2:
I’m trying to upgrade to leap 15.0. I know I have previously to upgrade to 42.3. But:
Starting to do a full backup with systemrescuecd using clonezilla on an USB pen (that works on another laptop) but here doesnt works, may be that this laptop could be UEFI boot, how can I test this?
And how can I have a clonezilla, or another working cloning backup software, working?

Following to see if leap 15.0 live on USB pen works (that perfectly works on another laptop), but it doesn’t and give this screen:
http://paste.opensuse.org/view/download/67336061
http://paste.opensuse.org/view/download/67336061
how can I solve and be sure that leap 15 works on this laptop??
manythanks :slight_smile:

EFI or MBR should not matter to clonezilla since it simply does binary copy of raw partitions.

If doing an upgrade be sure you removed the NVIDIA driver, if it was installed, first.

On Optimus hardware you must use bumblebee if there is no way to turn off the NVIDIA chip from the UEFI/BIOS. Unfortunately NVIDIA has not seen fit to support Optimus on Linux.

It is probably trying to use your Nvidia graphics. I’m basing that on the “nouveau” lines in the messages that you report. And that is likely to be the problem.

Your computer is new enough that it probably is UEFI. But it might also support legacy booting. The output that you provided does not give any hints on how you booted. If you also have Windows on that computer, then you need to install openSUSE to boot the same way as Windows.

Your best bet might be to append " nomodeset" to the kernel boot line. That should get your system booted into the installer. You can work on graphics issues after installing.

Take a look at my blog post Leap 15.0 - booting the installer. It explains how to recognize whether you are booting the installer with UEFI or with Legacy booting. And it attempts to explain how to append " nomodeset" to the kernel boot command.

Manythanks gogal, but I cannot boot the usb pen with clonezilla inside to do a binary copy of raw partitions

That laptop is definitely UEFI booting, but you can enable the so-called “compatibility mode” or CMS in BIOS if you have an USB drive that just boots in legacy mode.
To boot an openSUSE 15 LiveDVD please have a look at therelease notes : you may have to add “nouveau.modeset=0” to the boot command line if it hangs.
Having a skylake CPU, you may have to add also "acpi_osi=! acpi_osi=“Windows 2009"” (without added quotes) if you are still not able to boot.
As already written, remember to uninstall the Nvidia driver if you are planning to upgrade. If you do a “clean install” though you don’t need bumblebee or Nvidia driver if you only occasionally use discrete graphics: DRI_PRIME should work out of the box with Leap 15.
(written from a somewhat similar N551)

ok manythanks nrick, I’m booting the live KDE and yes, two things says to me that I’m booting UEFI, one is your blog post, I have a window only with commandline and edit in the lower left part, the second is the bios that to set the boot from usb pen says me UEFI.
I inserted “nomodeset” and leap 15.0 seems to works, bad resolution but works.
Tomorrow I can try to solve how to do a full backup booting the systemrescuecd from usb pen in UEFI mode.

Manythanks orso, I intend to do an upgrade not a clean install. and I think I’m not using nvidia drivers but I’m not sure and I will check :slight_smile:

maaaanythanks orso, I enabled the launch of CMS and systemrescuecd booted so I can do a backup, unfortunatly I cannot use partimage becouse it does not support ext4, I didn’t succeed with clonezilla so I used dd and cp from this very useful site :slight_smile:
https://wiki.archlinux.org/index.php/Disk_cloning_(Italiano)

reading release notes “…the Nouveau driver for Nvidia graphics card may hang at reboot, shutdown, or during runtime power management actions…” so, I have to insert “nouveau.modeset=0” when I start the upgrade from the usb key, and also I have to wait the reboot and insert “nouveau.modeset=0” again at the reboot??

manythanks again, my actual boot kernel parameter are:

splash=silent quiet showopts acpi_osi= acpi_backlight=native 

if I’ll have problems to boot I’ll try your suggestion

You have to use “nouveau.modeset=0” until you upgrade to the latest kernel, but if you enable the online repositories during install the last kernel should be installed even before the firs reboot…

manythanks again, my actual boot kernel parameter are:

splash=silent quiet showopts acpi_osi= acpi_backlight=native 

if I’ll have problems to boot I’ll try your suggestion

"acpi_osi= " disables _OSI from the start; if it works for your laptop there is no need to enable the “Windows 2009” string (making openSUSE pretending to be Windows 7…).
You might notice some ACPI errors at boot with the "acpi_osi= " option, but those are usually harmless.

Maaaanythanks to everyonelol!
Everything seems to be ok, upgrade to 42.3 went very softly, for upgrade to leap 15.0 I had to use “nouveau.modeset=0” to boot the 15.0 installer, there wasn’t nvidia drivers installed so I didn’t need to uninstall, refused the nouveau DRI/3D and removed the block to remove the mesa-dri-nouveau as I did here , enabled only packman and switched packages, the wine software I need works, dual boot windows10 works, sound and videos works.
I have to test only printers and scanners

with these experience I hope the next 2 upgrades I didn’t need help lol!