Firewall problems in v12.2

I have recently installed v12.2 after using v11.4 for about the last year. Had no problems with that but I am having lots of problems with the upgrade. I thought yesterday I had finally solved some of these - accessing other computers in the workgroup with Samba, printing to a print server - by disabling the firewall. All seemed good again

Today I have switched on the machine and now I can’t print, I can’t access other computers. The firewall is not running - I disabled it on startup. All I did was log out and switch off, then boot up and login today. I would also note that in Yast>>Firewall the buttons to start and stop the firewall aren’t functioning.

Also not sure if it’s the same issue, but in Okular I can’t print except to PDF or PS.

I am about ready to throw in the towel on this distro, I am wasting too much time trying to get a productive environment.

Mike

Are you sure the network runs? I.e. can you connect to the internet, can you ping the IP’s of the other computers?

I have internet connection. I can ping 192.168.1.3, which is the print server.

Mike

On 2012-12-06 13:06, mikejd wrote:
>
> I have recently installed v12.2 after using v11.4 for about the last
> year. Had no problems with that but I am having lots of problems with
> the upgrade.

Is that a real upgrade, or a fresh install? Please clarify.

Online upgrade
method

Offline upgrade
method

Chapter 16. Upgrading the System and System Changes


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Fresh install from cover DVD on Linux Format.

Can you reach http://192.168.1.3:631 ?

No. Sorry it’s a bit terse but that’s it.

Mike

On 2012-12-06 15:46, mikejd wrote:
>
> No. Sorry it’s a bit terse but that’s it.

Then it is your print server which has stopped working…


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

To add to my confusion:
I tried rebooting this machine with the print server still running. when I logged in I checked with Smb4k and it found the workgroup but could only see itself in that group not the print server. It also indicated that the IP address for this machine is 192.168.1.3.

The print server has always been 192.168.1.3, set manually. This machine has the IP address assigned automatically - I did try to assign it to 192.168.1.4 as I had previously but (in Yast) could not get this to work. Using ifconfig on this machine the IP address for eth0 is192.168.1.3; the print server is also apparently 192.168.1.3.

It seems to me this is probably the problem. Any ideas for sorting it?

Mike

Not clear what’s going on. Are you saying the client machine also has 192.168.1.3? That should be impossible. Is printersharing on in the printer config?

That seems to be the situation. I run ifconfig on each machine and both report

inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0

I have tried Yast>>Network Services on this machine - untick ‘Change hostname by DCHP’, then edit eth0 to statically assign IP 192.168.1.4 and add DNS servers 192.168.1.1. Then I lose the network connection and can’t access the internet.

This was all working perfectly well using v11.4 with the two computers as 192.168.1.3 and 192.168.1.4, statically assigned.

In Yast>>Printer>>Share printers the ‘Deny remote access’ was ticked so I have changed this to enable remote access to all computers on the network.

I have to leave this now, time run out today. Can’t get back until tomorrow pm. Thanks for your help so far.

Mike

On 2012-12-06 16:56, mikejd wrote:

> It also
> indicated that the IP address for this machine is 192.168.1.3.
>
> The print server has always been 192.168.1.3, set manually. This
> machine has the IP address assigned automatically - I did try to assign

Ok, the issue is clear, if I do some assumptions and guesses.

The print server is set manually to an IP.

Your machine gets automatically the same IP.

Thus you have a DHCP which is not properly configured, because it
doesn’t have listed that IP in the fixed IPs, which can not be handled
out to DHCP clients.

So, you have to find out how that DHCP server is configured, and reserve
a range of IPs that will not be given out, and then put the printer
server inside that range.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

OK, I understand that the same address is being assigned but not sure how to configure the DHCP. Is this the same as the DNS name server? In which case the DNS name server listed for the statically set IP address on the print server is the router; and I don’t know how to configure this.

How about if I set the static IP to a number sufficiently high that it shouldn’t be automatically assigned?

Mike

Additional to above post:
I logged in to both computers this afternoon. Check ifconfig on both; print server is 192.168.1.3 and this machine is now 192.168.1.2. I can now print to the printer from LibreOffice and Okular. However, I still can’t see the workgroup in Dolphin>>Network or in Smb4k so am unable to share files across the network.

On 2012-12-07 13:46, mikejd wrote:
>
> OK, I understand that the same address is being assigned but not sure
> how to configure the DHCP.

It typically is in your router.

> How about if I set the static IP to a number sufficiently high that it
> shouldn’t be automatically assigned?

Not guaranteed. Find out how your dhcp server is configured in your router.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Thanks robin_listas. I realise you won’t know every router but under Advanced set up>>LAN the DHCP is enabled with a start and stop address - 192.168.1.2 & 192.168.1.255 respectively. If I change the start to, say, 192.168.1.10 would this do the trick?

There is also something called ‘Fixed DHPC mapping.’ I which I add a MAC address and the IP address.

Mike

On 2012-12-07 15:26, mikejd wrote:
>
> Thanks robin_listas. I realise you won’t know every router but under
> Advanced set up>>LAN the DHCP is enabled with a start and stop address -
> 192.168.1.2 & 192.168.1.255 respectively. If I change the start to, say,
> 192.168.1.10 would this do the trick?

Yes, that’s the trick :slight_smile:

> There is also something called ‘Fixed DHPC mapping.’ I which I add a
> MAC address and the IP address.

Ah, that’s another way. You enter the MAC address of a computer, and the
IP you want it to have, in the router. Then you configure the computer
to use automatic network configuration, and it will always get the same
IP that you wrote in the router. It is effectively a fixed IP.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Thanks, robin_listas, I’ll give it a whirl.

Changed the router DHCP settings and rebooted this computer. it is now 192.168.1.10. I didn’t reboot the print server so that is still 192.168.1.3. I can print to the server and I can see the other computer in Dolphin so could swap files. Assuming the print server will always be the same IP, looks like it’s sorted.

Many thanks.