Firewall problem with remote X


I have setup my Solaris 10 box so that I can access it from my Suse 11 box using Xnest :10 -query <hostname>

They are on my local home network behind my ADSL firewall/router

The problem is that when I enable the firewall on Suse I can no longer connect, in spite of allowing XDMCP traffic through. I tried allowing “remote desktop access” as well, but it still didn’t work.

Does anyone know what further ports I need to enable so that I can keep my firewall running on Suse?


Are you saying, that if you disable suse firewall it works?
Are you allowing by service or manually opening ports?

yeah, it works when I disable the suse firewall.

I’ve been configuring the firewall using the gui in yast. It has a predefined xdmcp service which I’ve allowed, I also tried creating a custom rule to allow UDP 177 traffic, but it just interpreted this rule as being the same as the predefined one. I’ve also just tried manually entering UDP and TCP ports 177, but it still won’t work with the firewall running.

You should use the Allowed Services – Advanced section to manually enter the TCP177 & UDP177 ports; maybe you did. The entries are a list separated by spaces.

That would be my choice too John. If you have the ports added in there correctly it will work.

Thanks for your help, managed to solve it in the end by capturing the network traffic with wireshark.

the Solaris box was sending data from TCP 33206 to TCP 6010 on my linux box.

When I opened TCP 6010 on the suse firewall (in addition to UDP 177) it worked fine. I found on a google search that X has its own TCP port, which on suse seems to be 6010.