firewall off no computers in network are visible


I have a network with 2 windows 7 computers and now 2 suse12.2. there is also a canon mg6120 connected by wifi.

The wifi printer is in general always visible whether there are other computers on or if I only use my android tablet to browse the network. Suse cannot see anything on the network. I opened up firewall settings and asked it to disable and turn off after conf is written.

apparently it takes a while for the firewall to turn off and now I can see the canon printer as an entity on the network. The canon install script still cannot get through to it though. there is no firewall in the way, it’s visible on the network, why can they not communicate? I know it’s worked before…

i configured workgroup membership as best i could. Connect to workgroup with no passwords etc. current domain, in networking, is “WORKGROUP”

Thanks for your help.

Last time I connected to a networked Canon printer I found that Canon uses some kind of unusual proprietary protocol.

Resolved it by finding and loading a proprietary driver for the specific model printer on the Canon support site.

The SUSE FW should not be an issue, if you see any changes due to a changed setting it’s likely co-incidental.


On 2012-09-25 19:46, bananapeal wrote:
> What do I do? I don’t know where to begin, none of the settings seem
> intuitive.

Start by pinging all machines from all machines.

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

You may be correct about the firewall. It is still running despite pushing the disable button as well as checking the disable auto-start box. I have set it to internal zone instead of external.

I have continued in my usual fashion of pushing related-sounding buttons. I have installed and configured samba to act as its own dc. not sure what that means, but it wouldnt connect to workgroup otherwise. I also noticed at this point, the canon printer became an entity on the network. I now see workgroup on the network in samba shares. Although I still cannot interact with folders shared with “everyone” in win7. tells me i need password. but no password set. gr.

I tried the install script again and it went thru and found the printer.

It is very difficult to figure out which of these actions did it.

Is it bad to open up the firewall and enable samba without security like this? The firewall is set to connect to “internal zone” on the wifi and I think I won’t change it when I go to a coffee shop for instance.

i would suggest to use swerdna’s instructions on how to setup Samba ( For some reason I get an error that he reached his maximum bandwith right now but hopefully later on the site is going to be available. After following the steps, ask specific questions and we will try to help.