Firewall not working || openSUSE 13.2

I am using openSUSE 13.2. I have enable the firewall through YAST. I havent opened any port but still when I launch qbittorrent and run a nmap scan I get

# nmap

Starting Nmap 6.47 ( ) at 2015-07-30 10:12 IST
Nmap scan report for
Host is up (0.000011s latency).
Not shown: 999 closed ports
6881/tcp open  bittorrent-tracker

My question is how is the port open despite no rules mentioned ? The firewall is not working ?

I have tried wiith upnp deselected in qbittorrent but same thing.

Two possibilities to check in YaST2 Firewall:

1.) Is “” on an internal zone (Interfaces), and is Protect Firewall from Internal Zone unchecked (Allowed Services)?

2.) Was the port opened when you installed qbittorrent?
Check in YaST > Firewall Configuration> Allowed Services > Advanced.

These are my settings

As you can see no external zone is added by default. How do I add my ethernet port to the external zone.

No, no that port was not opened atleast by me at the time of qbittorrent installation.

Why do you think that anyone would want to download files from an anonymously owned site in Costa Rica or anywhere else? This forum has a perfectly adequate means of uploading images. Anyway I have very diminished eyesight and mostly use text mode or text-to-speech.

YaST > Firewall Configuration > Interfaces
This lists your enabled network devices/interfaces.
Select the required interface .
Select [Change] and choose the appropriate zone.


YaST > Firewall Configuration > Allowed Services

  • Protect Firewall from Internal Zone*] check/uncheck as required.

YaST > Firewall Configuration> Allowed Services > Advanced
This allows you to see, add and remove ports from the firewall that do not appear in the "YaST > Firewall Configuration > Allowed Services " drop-down list.

PS How is the torrent client meant to operate if it cannot communicate with (upload to) the outside world?