Firefox won't start as non-root

Why don’t you remove all Mozilla components, then reinstall:

zypper remove songbird mozilla*

Install Firefox again after that, and if that works, then install songbird.

removed all mozilla*, songbird.
Installed firefox.

Same problem. :frowning:

On 10/19/2009 12:06 AM, inheritthewind wrote:
>
> GIMP opens fine.
> This confuses me.
>
>
>
> - If GTK apps open fine, then it must be a firefox settng.
> - If firefox opens as another non-root user, it must be a user
> specific setting under ~/.
> - If removing ~/.mozilla doesn’t fix it, there must be settings
> elsewhere.
>
> I looked all the way through my home folder and couldn’t find anything
> obvious.
>
>

What is the content of $PATH for the troubled account? Can you compare
this with the account where you can start FF ok?
What’s the path to your FF installation?
Not a solution, just some thoughts.


Christian

I copied all my data to a new user, logged in, guess what - no Firefox, no Songbird.
Then I discovered something strange - my old account worked from the terminal - logged in locally as this new user.

As it turns out, whatever user is logged on locally to a desktop session, is unable to run the apps.
Su - to any other user, and they work (albeit with a warning - Xlib: extension “Generic Event Extension” missing on display “:1029.0” - I get this everytime I close a YAST module though).

This is beginning to look like a re-install job.

Have you tried firefox in safe mode? I have that built into my menu.

firefox --safe-mode 

Many times, I’m afraid. Doesn’t make any difference.

I’ve seen all this lately at a friend’s. Please check if an instance of FF is already running immediately after login. Make sure you’re the only one logged in, and do ‘ps -ea | grep firefox’ in a terminal window. If it spits out a firefox process, do ‘killall firefox && firefox’ and see if it starts now. At my friend’s that was all. It appeared the session manager saved a copy of a dead FF process and tried to restart it on next session, thus blocking a new instance.

This sounds promising. I have a console session and a remote NX session on the PC simultaneously. At first I wondered if it was an NX session bug, but the same issue exists on the console (and I’ve being using firefox in this configuration for years).

I’ll try your solution when I get back from work. Thanks for your suggestion.