Firefox won't run feed program.

I have a script that directs RSS feeds to akregator or amarok. I entered it as a feed reading application in the relevant box. Firefox 3 doesn’t run it at all. This is NOT a script programming issue as the script worked fine until the actual release of Firefox 3 and after some debugging, I’ve ascertained that Firefox doesn’t run it at all. Many people use this script, akadd, and it is available on the web. I gather that non-SUSE users have no problems with the script.

Any way to diagnose the issue??

Are you using the latest version of Firefox from Mozilla repository?
What says the Error Console in Firefox?

I am running the most current version of Firefox. This has been going on since version 3. Here’s the error message:

Error: [Exception… “Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]” nsresult: “0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)” location: “JS frame :: file:///usr/lib/firefox/components/FeedConverter.js :: FRS_addToClientReader :: line 415” data: no]
Source File: file:///usr/lib/firefox/components/FeedConverter.js
Line: 415

Hmmm… this will be a script related issue at line 415. Can you post here your

FRS_addToClientReader(spec, title, subtitle, feedType)


Okay, I don’t think so that it will help for us. BTW, if you google a little for you error message you can find another users with exactly the same problem.
Bug#406380: External RSS application not launching - linux.debian.bugs.dist | Google Groups

My Line 415 reads: getService(Ci.nsIShellService);

It is embedded in this paragraph:

var ss =
ss.openApplicationWithURI(clientApp, spec);

The line that you quote is at line 382.

:slight_smile: Yeah, I know. …and I’m wanted the whole function…
Try one of the links from my previous post.
Good luck

Thanks for all your help. I’ve checked the links, but they haven’t fixed the problem. Here’s the entire function:

addToClientReader: function FRS_addToClientReader(spec, title, subtitle, feedType) {
var prefs =

var handler = safeGetCharPref(getPrefActionForType(feedType), "bookmarks");
if (handler == "ask" || handler == "reader")
  handler = safeGetCharPref(getPrefReaderForType(feedType), "bookmarks");

switch (handler) {
case "client":
  var clientApp = prefs.getComplexValue(getPrefAppForType(feedType), Ci.nsILocalFile);

  // For the benefit of applications that might know how to deal with more
  // URLs than just feeds, send feed: URLs in the following format:
  // http urls: replace scheme with feed, e.g.
  // -> feed://
  // other urls: prepend feed: scheme, e.g.
  // -> feed:
  var ios = 
  var feedURI = ios.newURI(spec, null, null);
  if (feedURI.schemeIs("http")) {
    feedURI.scheme = "feed";
    spec = feedURI.spec;
    spec = "feed:" + spec;

  var ss = 
  ss.openApplicationWithURI(clientApp, spec);

  // "web" should have been handled elsewhere
  LOG("unexpected handler: " + handler);
  // fall through
case "bookmarks":
  var wm = 
  var topWindow = wm.getMostRecentWindow("navigator:browser");
  topWindow.PlacesCommandHook.addLiveBookmark(spec, title, subtitle);


Probably there is no problem with this function.
I’m tried to subscribe for rss feed with akregator from mozilla.
First of all, I found this bug:, but the feed is added to akregator.
BTW, why are you using scripts for subscribing - you can directly do that from Firefox.

How do you do it directly? If I put akregator directly in the RSS dialog, then I get the exact same error I get with my script.

On any site with RSS feed i click on the RSS icon next to the link. In the Subscribe to this feed using -> I select akregator executable (/usr/bin/akregator) -> Hit Subscribe Now.
Edit -> Preferences -> Applications -> Web Feed (select here akregator, or another application.) - this option will be used as default.
If it isn’t works for you then probably something is wrong with your Firefox, or something is missing.
I recommend you to do a quick search in yast for “mozilla”, and post here the list of installed packages.

That is exactly what I did. I still get the same error.