Firefox Won't Play Media on Twitter Even w/ Flash 24 Installed

Hey guys,

I’m a new poster, so please be gentle with me.

I’ve installed the Flash plugin (version 24) from the official Adobe repository, but some media (such as GIFs) on Twitter still does not play. Chrome plays them fine, and on Ubuntu, Firefox can play them too, presumably because I selected to install proprietary software when installing the OS. I’ve been tearing my hair out trying to figure out how to get Firefox to play this media in openSUSE, but haven’t been able to figure anything out.

Can anyone help me?

IMHO this is not a Network/Internet problem, but a Multimedia problem.

This one seems to be related:
And this one:

And in the Multimedia subforum, you will find in the first few sticky threads all the information to get multimedia running on openSUSE.

One way to do that switch:

YaST > Software Management, then from the View menu choose Repositories. Then in the list of repos, select Packman. At right, above the list of Packages there is a line saying something like: Switch system packages to … Click on the underlined part and continue low-right.

Thank you for your response, the first link solved my problem completely.

I admit I wasn’t sure about where to file this – this is my first-ever post on these forums – it was a toss-up btwn Internet & Multimedia & I probably picked the wrong one. Thank you for the response regardless!

Sometimes it isn’t clear what the best forum is. The best is of course the one where you can expect the members knowing about your subject . But we will try to help you in any case. When needed moving the thread to the “better” forum.

But as your problem is solved that result is what counts.

Enjoy openSUSE.