FireFox won't play FaceBook Videos/GIFs

I have take several strategies to try to see why Firefox is not playing Videos and GIF Animations (e.g. Giffy) on Facebook, yet has no issues anywhere else I have encountered (e.g. YouTube: good).
I have adjusted settings on FF.
I have download the version from the Mozilla Website and am on it now.
I have checked the Mozilla Forum.
Tried Safe Mode.
And other things.
None of the other “mozilla-based” Web Browsers work either, where Facebook is concerned.
As for Chromium and Google Chrome, not problems on those.
Firefox allows multiple profiles, which works arounds issue of different profiles with Chrome wanting to have different email accounts (for the Google stuff). I’m sure I could undertake some workarounds, like maybe just have a “Facebook” profile for a different Chrome profile. I have been using Firefox for years, and had hope to continue with FF.

The Google web-browsers have “Google-own” functionality for Adobe Flash content; Firefox doesn’t.

You may have to install the Adobe Flash-Player, which isn’t included by default in openSUSE for licensing reasons.The instructions for installing the Flash-Player from an Adobe repository (fully supported and, for individual human beings, legal) are here: <https://en.opensuse.org/Adobe_Flash_Player&gt;; the reason why openSUSE can no longer bundle the Flash Player with the distribution is also stated there.

most of those so called gif animations are in fact mp4 video’s without sound they use h264 compression which is patented by the mpeg-la to avoid patent violations Firefox uses the OS’s support for it, seeing how opensuse is open and does not contain any patented code you need to replace the system ffmpeg with one from packman which in turn does have all multimedia support (different countries different laws) do (you can get flash from packman too but it’s not needed for facebook video’s)

zypper ar -f ftp://packman.inode.at/suse/openSUSE_Leap_42.3/ packman
zypper dup --from packman
zypper in vlc-codecs libxine2-codecs flash-player

that should make all multimedia apps work not just Firefox

I would like to express my most heartfelt thanks to all of you that have replied and offered assistance, for now the issue is surely solved. All to the best to you and yours to each of you all.

Clifton

I have the same problem, with Firefox Quantum 61.0.1 and all the packages installed.
Any help?
Thanks!

For Leap 15.0:
https://forums.opensuse.org/showthread.php/532171-H-264-not-working-in-Firefox-60-1

For Leap 42.3:
https://forums.opensuse.org/showthread.php/532411-Lost-support-for-H-264-video-in-browsers