Firefox won't load

Firefox won’t load. On clicking the icon in the plasma box the bouncing loading icon appears but after about 30 secs it disappears and nothing further happens.

I am running Suse 11.1. Not sure of the original version of FF! I have tried deleting it in Yast and reinstalling the latest version with the same result. It certainly used to work but as the machine is primarily a mail server, FF is not used much.

Any ideas?

Hello rcrosoer,

Could you post the output of firefox when you run it from terminal?

If you’re sure it did work before it’s most likely a wrong settings.
So run this command to rename your .firefox folder:

mv ~/.mozilla/firefox/ ~/.mozilla/firefoxBU/

Then try to restart firefox.

In your firefox folder are all your firefox settings and add-ons.
So if you rename your firefox folder it’s just like a fresh install.

If it didn’t work you can get your settings back with this command:

mv ~/.mozilla/firefoxBU/ ~/.mozilla/firefox/

Best of luck!:wink:

Couldn't load XPCOM

I get the same result renaming the firefox folder too.

I think you might need to install XULrunner or some other dependency of firefox related to XPCOM

Also this page might help you:

According to Yast I have xulrunner 1.9.1 loaded,

The FF is 3.5.10

Have a look at this thread:
Upgraded Firefox won’t fire up

The Firefox and openSUSE versions were different, however the error was the same, i.e. “Couldn’t load XPCOM.” The culprit was the package mozilla-js192 which came from the Packman repo.

Looks similar but this is a 32 bit system and I don’t have the mozilla-js192 package. There is no link to but even when I create one it still doesn’t load.

Hello rcrosoer,

Could you post the output of this command:

ldd -d -r /usr/lib/firefox/firefox

Best of luck!:wink:

I have 32 bit too and I had the same problem then. In any case, if there is no mozilla-js192, you could still see that there are no Mozilla packages coming from anywhere else (i.e. Packman) than from where your Firefox installs comes (OSS? Mozilla?).