firefox won't apply theme

Hi. This is a very minor thing. Yesterday Firefox was updated to version 20. Now it won’t apply themes (Tools -> Add-ons -> Appearance). I can click through a list of themes, enabling and disabling them, but in the end, all I ever see is the default theme. I’ve tried restarting Firefox, logging out and logging back in, and restarting the laptop. Same deal. Themes are applying fine in Thunderbird, which updated at the same time. Anyone else seeing this?

  1. 3 (KDE)

The profile might be corrupted. Close Rename ~/.mozilla folder in and start firefox and check whether the issue is still present. You can revert back to old profile by undoing the “rename”.

Maybe someone else can test this. I lose my theme where I select 'Never remember history" from the “Privacy” option tab. This is perfectly repeatable: rename Firefox folder -> start Firefox -> add theme (I use “Kavalkad 3”) (theme appears) -> change privacy setting to “Never remember history” (theme disappears on Firefox restart).

You might want to give this addon a try:
https://addons.mozilla.org/en-US/firefox/addon/checkcompatibility/

WFM

One more thing despite what it says it works better if you restart Fx after installation.

Thanks for the reply. I’ve already tried that with no effect. The theme works fine, except when when “Never remember history” is selected. I’ve just adopted a work-around using “custom settings for history”. Probably it’s a bug. I feel foolish asking, but where do I go to file a bug report?

It is not a foolish question at all. It is rather wise to ask question when in doubt .I would download the binary from Index of /pub/mozilla.org/firefox/releases/20.0 or here Mozilla — Home of the Mozilla Project — mozilla.org and check whether the issue exists in those builds. If it exists raise a bug report at mozilla’s bugzilla http://bugzilla.mozilla.org . If bug exists only in openSUSE’s version then raise a bug report here http://bugzilla.novell.com/. Also recommended that you read through openSUSE:Submitting bug reports - openSUSE Wiki

The issue exists in binaries from Mozilla. I’ve filed a bug report here.

Your’s has been marked duplicate of 852295 - LW Themes do not display in Permanent Private Browsing mode post Per-Window PB

and the bug will probably fixed by version 22 (hope mozilla22 means version 22)

I read somewhere that from v.20 it does not work in you have ‘Private Browsing’.
If you uncheck ‘Private Browsing’ then Firefox 20 restarts and you have your theme/personas. Otherwise does not work.