Firefox Video Downloads Being Saved to /tmp and Automatically Loaded and Run By Xine-UI

Hi, openSUSE 11.3, recent install, fully updated. Running Firefox 3.6.13 from Mozilla, not openSUSE branded version.

Just today when I download a video file from a file sharing site like Megaupload, Firefox has not been asking me where to save the file despite the checkbox for “Always ask Me Where to Save Files” being checked in its settings and showing as being true in the about:config dialogs.

And when the file is downloaded, it is downloaded into the /tmp directory, from which xine-ui grabs it and starts playing it automatically as soon as the download is finished. Which is not something I’ve requested it to do!

I play most of my videos using Kaffeine, but have just today installed xine-ui and smplayer plus some of the other recommendations from the multimedia recommended practices document referenced here often.

I’ve looked in Firefox’s about:config and can’t see where the behavior is being allowed. I suspect it has something to do with a plugin, but there is no xine-ui plugin installed that I can see in either Firefox’s plugins settings or in the Firefox plugin directories.

Anyone have any idea how I can 1) stop Firefox from not asking where to save the files, and 2) stop xine-ui from automatically playing them? Or any ideas exactly where to look where this behavior might be being set?

Hi, openSUSE 11.3, recent install, fully updated. Running Firefox 3.6.13 from Mozilla, not openSUSE branded version.

Just today when I download a video file from a file sharing site like Megaupload, Firefox has not been asking me where to save the file despite the checkbox for “Always ask Me Where to Save Files” being checked in its settings and showing as being true in the about:config dialogs.

And when the file is downloaded, it is downloaded into the /tmp directory, from which xine-ui grabs it and starts playing it automatically as soon as the download is finished. Which is not something I’ve requested it to do!

I play most of my videos using Kaffeine, but have just today installed xine-ui and smplayer plus some of the other recommendations from the multimedia recommended practices document referenced here often.

I’ve looked in Firefox’s about:config and can’t see where the behavior is being allowed. I suspect it has something to do with a plugin, but there is no xine-ui plugin installed that I can see in either Firefox’s plugins settings or in the Firefox plugin directories.

Anyone have any idea how I can 1) stop Firefox from not asking where to save the files, and 2) stop xine-ui from automatically playing them? Or any ideas exactly where to look where this behavior might be being set?
So I made a visit to Megaupload, did not join and downloaded one HD Movie Trailer and Firefox asked where to download as normal. I then played it by selecting open in the file download window. So, I must ask have you installed a Megaupload plugin by chance (Tools / Addons / Plugins and look carefully through the list)? Since it worked at first, it has got to be a recent addin to Firefox as the only explanation I can think of and/or the response by Firefox to the file type/extension has changed (Edit / Preferences / Applications).

Thank You,

richardstevenhack wrote:
> Hi, openSUSE 11.3, recent install, fully updated. Running Firefox 3.6.13
> from Mozilla, not openSUSE branded version.

perhaps there is a difference between the firefox in the openSUSE
repos and the one you have…if the one in our repo has that bug
please log it in our bugzilla, here
http://en.opensuse.org/Submitting_Bug_Reports

but, if the one you have from mozilla has that bug then discuss that
in the moz forums and log that bug with mozilla’s bugzilla…


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]
I feel annoyed that I can’t put my wide range of languages on stupid
Facebook. For example, I speak Sarcasm, fluently spoken and written,
and Various Forms of Geek…

Oops, forget it, it’s my own bloody fault again!

Since installing xine-ui, Firefox has been popping open the download dialog with the download option defaulting to “open with xine-ui” instead of “save file” as it usually does and I haven’t been noticing, just clicking save. Dumb, dumb. Caught myself doing that finally. Problem solved.

Oops, forget it, it’s my own bloody fault again!

Since installing xine-ui, Firefox has been popping open the download dialog with the download option defaulting to “open with xine-ui” instead of “save file” as it usually does and I haven’t been noticing, just clicking save. Dumb, dumb. Caught myself doing that finally. Problem solved.
Well at least you found the problem and got it fixed.

Thank You,