Firefox Up and Down Arrows


I am using Firefox 37.0.2 on OpenSuse 13.1. The up and down navigation arrows on the navigation bar on the right hand side of the screen are missing. I have tried using a different theme but it still does not work.

Please assist

Sounds like:

Which desktop environment are you using? How did you change to a different theme?
Firefox is a GTK2 application so just switching the desktop’s theme probably won’t affect it (at least not with KDE and GNOME).
If you use KDE, try to change the GTK2 theme in “Configure Desktop”->“Application Appearance”->GTK, the Oxygen theme works fine here with Firefox.

I am using Gnome. I changed the theme using the Firefox Add-On option.

Well, I don’t use Firefox much and I don’t use Firefox themes at all.

But at least by default (without setting an explicit theme), Firefox uses GTK2 and its configured theme for UI elements like the scrollbar arrows.
So again, try to change that.
But as I don’t use GNOME either, I have no idea how to do that the best way. GNOME3 is GTK3 based, setting the GNOME theme will only change the GTK3 settings AFAIK.
But the GTK2 theme should be stored in ~/.gtkrc-2.0 IIANM, try to edit that manually it should contain something like this to set the theme:

include "/usr/share/themes/Adwaita/gtk-2.0/gtkrc"

and then:


Maybe there’s a better way to set the GTK2 theme in GNOME but I don’t know (as I said, KDE does allow this in its settings).

Themes are stored in /usr/share/themes/, so have a look there what themes you have installed (note that only those with a “gtk-2.0” subfolder apply to GTK2).
It might of course also be possible that the theme you have set is not installed, and that’s maybe reason for your problem in the first place.

Btw, I just tried to set Adwaita (GNOME3’s default) as my GTK2 theme, and this indeed doesn’t show any arrows. Must be a problem (or a design choice?) in that theme.
oxygen-gtk (which you probably don’t have installed if you are using GNOME) should work though, as do most other GTK2 themes I have installed and tried (ClearLooks, Crux, Gilouche, Sonar, Redmond, Raleigh)
I think Raleigh should be installed by default in any case, so try to modify ~/.gtkrc-2.0 that it looks like this: (that’s what my KDE settings generated)

include "/usr/share/themes/Raleigh/gtk-2.0/gtkrc"
include "/etc/gtk-2.0/gtkrc"
style "user-font"
        font_name="Sans Serif "
widget_class "*" style "user-font"
gtk-font-name="Sans Serif  9"

You should get arrows then. (you might not like the look of it of course, but that’s a different story)

I cannot help you more I’m afraid, maybe someone actually using GNOME could join in. I can’t believe that you’re the only one seeing this as the default Adwaita theme apparently just doesn’t have any “arrows”.

Thank you for your very detailed feedback, it is appreciated. I read on the net that there are a couple of users having this issue on various operating systems. Some had this issue on Chrome and when they switched to Firefox the issue was no more. Other Linux distros also had this issue and some was on KDE as well.

I will try to do what you have proposed and see if it works.

Thanks once again.