Firefox/Thunderbird Will Not Open (Somewhat Urgent)

For some reason today when I get to work, Firefox nor Thunderbird will open. I have tried to restart, reinstall but none of this seems to help. Does not matter what Desktop Environment I am using either. When opened from command line this is what I get.

jonw@JonsWorkstation:~> firefox
/usr/lib64/firefox/firefox: symbol lookup error: /usr/lib64/xulrunner- undefined symbol: PR_GetEnv
jonw@JonsWorkstation:~> thunderbird
/usr/lib64/thunderbird/thunderbird-bin: symbol lookup error: /usr/lib64/thunderbird/thunderbird-bin: undefined symbol: PR_GetEnv

This is my work machine and I don’t, I am in a little bit of a hurry to get this functional again.

try uninstalling them and reinstalling see if that works.

> This is my work machine and I don’t, I am in a little bit of a hurry to
> get this functional again.

any particular reason you are using 64 bit? (work with huge files, etc?)

you could try installing 32 bit firefox/thunderbird…see if they work…

see caveat:
DenverD (Linux Counter 282315) via NNTP, Thunderbird, KDE
3.5.7, SUSE Linux 10.3, #1 SMP i686 athlon

Sorry for not saying it, but that is what I did to reinstall it. I completely uninstalled it and also made sure the offending lib packages were removed from the lib64 directory. Thanks for the quick reply though.

If I download the programs from Mozilla it works, this is less than optimal though. Since then I also have tried running Firefox as root (just to see if it would open) and also from a different user. No luck there either.

I also did not see the post before that. As for installing the 64 bit, it is installed because that is what Yast gave me by default. Installing the 32 bit versions seems to allow them to open and I am fine with that. It jacked up the display with Lightning but that is most likely because it was the 64 bit extension. I will look into that later.

For now I guess I will use the 32 bit version, I am sure I will not notice a difference. I would just like to know what happened to cause this, so I don’t do it with the 32 bit version.

Thanks for your quick help.

This could be due to a mismatch of versions between mozilla-xulrunner and firefox. If you want to reinstall firefox, you should try reinstalling both the mozilla-xulrunner and firefox (version 3) packages from the update repository (or the openSUSE Build Service). You have to do this with the 64-bit version also.

Have you tried removing the configuration files from the home directory… .firefox or .monzila… and try to restart it… if that doesn’t work try unsinstalling it this time remove the firefox hidden configuration file and reinstall the firefox… Home its a configuration problem…:wink:

Thanks again for all the help. When I tried to open Firefox on a clean account (never opened Firefox before) it still failed. When I reinstalled Firefox after deleting everything, I made sure that the xul_runner was the most recent as well, still did not fix the problem. Is there a way to know exactly which version Firefox is looking for?

This is a BUG in FF3(.0.1), especialy with multiple profiles.
The FF team really screwed this one up. Several Forums are filling up with this symptom.

Work around : If you open Windows Task manager, you’ll see a FF process, but nothing happens. Kill this process, then open FF (and leave it open). If you click now on a link in TB, they will open in the FF browser you just launched.

No Solution Yet.