Firefox/Thunderbird & openSUSE 11.0 KDE4

OK. I just installed openSUSE 11.0 with KDE4. My Firefox & Thunderbird work in Root, but when I login as a user, I get the following message when trying to start these apps…

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

I copied my .mozilla and .thunderbird folders from my old /home/username folder to the new one I created under 11.0

When I look in the Systems Activity they are not running. Anybody recognize the problem and know a solution?

You probably copied your profiles while the apps were running and as a result also copied the lock file which indicates that an instance of the app is running. Search for the lock files and delete them.

cd
find .mozilla .thunderbird -name lock

Then try again.

I did indeed. I used MyComputer to browse and delete the lock files. Unfortunately, even after a reboot. The problem still exists.

Ok. It’s a problem. When I traverse the directory tree using MyComputer, I see only my original directory tree in .mozilla. When I traverse the directory tree using Terminal, I see a new .default directory. In there is a lock file which I never saw using MyComputer. So. Another bunch of questions…

  1. Why do I not see this .default directory tree using MyComputer? How do I “sync” these 2 views?

  2. What is the terminal command to delete a file? I tried “del”, “erase”, “kill”.

  3. Finally. why did Firefox/Thunderbird create new default folders, when folders already existed (from copying my .mozilla & .thunderbird directories from my old installation)?

Ok. I found out the /home/username/.mozilla is using the same profile as the /root/.mozilla profile. Shouldn’t they be different? How to fix?

This problem went away after I reinstalled 11.0 with KDE3.5 and I then copied my .mozilla and .thunderbird folders again. Then opened Firefox/Thunderbird for the first time whilst logged in as user. Haven’t tried as root yet, but then I don’t normally use these programs in root. I don’t think swapping to KDE3.5 had anything to do with it, but I much prefer it to KDE4.