Firefox sync not syncing

So… went ahead and backed up a few things, popped the 12.2 DVD in the tray, and installed openSuSE over Ubuntu 12.10 on my dual-boot PC.

One of the things I knew I was going to need to set up was Firefox Sync, and since my laptop is DOA right now, I can’t just copy the pairing codes from one to the next. I wrote down the recovery key, and entered it in Firefox once I had SuSE up and running. It accepted it okay… but it ain’t syncing - nothing.

Any idea what might be the culprit here?



I have never used Sync, but this Mozilla Support article may help you.

Had you ever tried pairing a device to the sync account before now? I ask because my first sync account I set up never worked properly and I had to remove it via the sync web site and start all over again. My suggestion would be to follow all the steps outlined on the support site and then as a last resort restore your ~/.mozilla profile from a backup and start over with a new sync account.

Had you ever tried pairing a device to the sync account before now?

Numerous times, actually. Multiple physical devices - Firefox browser in Win Vista and Ubuntu Linux on both my desktop and my laptop, on Portable Firefox from a USB stick, and in various VMs where it was convenient to have the same browser book marks as my main desktop. More times than I can recall, and its always worked flawlessly.

The only difference this time is that I didn’t actually have the pairing codes - because my laptop was TU, and I was in a fresh install of SuSE, so none of the other VMs or Portable Firefox were available to me. This time I was trying to do it via the Recovery Key, which didn’t work at all.

A new laptop showed up Wednesday and I’ve been busily imaging, updating, syncing with Dropbox and Firefox Sync, imaging again, creating system restore disks, etc. Now that everything is sorted out on the new machine, I’ll probably just use the pairing codes method to kickstart Firefox Sync on the PC.