Firefox Sound - No Sound

I’m running Tumbleweed/KDE, here’s some inxi output:
System: Host: linux-664c Kernel: 4.7.6-1-default x86_64 (64 bit gcc: 6.2.1) Console: tty 0 Distro: openSUSE Tumbleweed
Machine: System: Gigabyte Tecohnology product: H61M-DS2 Mobo: INTEL model: H61M-DS2 v: x.x Bios: American Megatrends v: F4 date: 12/21/2011
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 Sound: Advanced Linux Sound Architecture v: k4.7.6-1-default

The problem is that some sites in Firefox do not play audio or video. does not work, (scroll down to recent archives) does not work, main stream works but ragtime does not, and displays a message ‘your browser isn’t capable of playing this media’, error 6. UTube, Riverwalk Jazz,, radio,, and radio all do work. Outside of Firefox, Quod Libet and Rhythm Box do work.

The following addons are installed and most are set to ‘Ask to Activate’:
openH264 video …
shockwave flash
divx web player
icedtea-web …
quicktime plug-in …
vlc multimedia …
windows media player …
iTunes App …
Skype Buttons …
VLC web plugin
Xine plugin
I have activated/deactivated various addon combinations to check for conflicts to no avail.

And, Firefox help is no help.

So, what to do?

a) Did it never work on your TW installation or is it something that started “overnight”?

b) You have installed a lot of Audio thingies, but fail to telll if you installed them from Packman. And apart from that you should have all Audio/Video from Packman. Thus the most important question: Did you do the “Switch to Packman”?

This is a new installation as of two weeks ago and it’s been this way from the start.

And yes, Packman is in use.

OK. That makes the second question even more urgent.

That is not enough for me. “In use” can mean a lot and is no exact specification on
it’s usage.

I reapeat: Did you do the switch to Packman?

Remember that in almost all of the cases here where people say something like “Player X does not play format Y” were solved by doing the Packman switch.
For most people here trying to help with such “X does not play Y” problems one thing must be 1000% sure that you did the switch 100% correct. Only when that is clear they will try to help with the cases that are still left.

When you are not 100% (or do not know what "Switching to Packman means) start YaST > Software > Software Management. Then from the VIEW menu choose Repositories. Then in the repo list at left select Packman. Then at right you have a list of Packman packages. Above this list is a text like

Switch system packages to …

Click on the underlined part, packages will be selected (or none if you already did the switch). Continue the installation. Then check your problem and report back here.

I went through the process you outlined and it seems to have solved the problem. Thanks a lot.

I spent two weeks working on this issue, wading through posts and instructions, and never coming across this rather necessary process. Oh well, live and learn.

Thanks again,

You are welcome.

It is described in the first “sticky” threads of this very Multimedia forum.