Firefox segfaults on


My firefox is segfaulting when I visit pages, including and the page (writing this on a different machine). If I run the program from terminal, I get this output:

/usr/bin/firefox: line 128: 5891 Segmentation fault    $MOZ_PROGRAM "$@"

Any ideas what I might do about this?

> Any ideas what I might do about this?

you might offer a little more info (like hardware, software) did this
“just begin” after running ok for days/weeks? did it immediately
follow a new addon being added? an update? a new program installed?
new RAM installed? a hard shutdown and reboot?

what changed?

can you browse with konqueror?

what is the results of

zypper lr -d

in a terminal?


Sorry about not posting basic info. opensuse 11.2, right after an install, all I did before starting firefox for the first time was check for updates. Running Gnome so I don’t have konqueror.

Hardware is a virtual machine running through wmWare Player with 1gb of memory.

zypper says that repo-non-oss (2), repo-oss (3) and repo-update (5) are enabled and (2) & (3) are type yast2 while (5) is rpm-md. Repos deub and source are not enabled. Sorry, I can’t copy/paste that from a terminal. Hope my summary is useful instead.

Thank you

You can copy and paste from a console by adding a Shift key. ie


or select from the menu.

Wow, I knew you could copy/paste from terminals, but I didn’t think a virtual machine would share clipboard with its host OS. Very nifty!

So here’s the output from zypper:

# | Alias        | Name                  | Enabled | Refresh | Priority | Type   | URI                                                             | Service
1 | repo-debug   | openSUSE-11.2-Debug   | No      | Yes     |   99     | NONE   |  |        
2 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes     | Yes     |   99     | yast2  |    |        
3 | repo-oss     | openSUSE-11.2-Oss     | Yes     | Yes     |   99     | yast2  |        |        
4 | repo-source  | openSUSE-11.2-Source  | No      | Yes     |   99     | NONE   | |        
5 | repo-update  | openSUSE-11.2-Update  | Yes     | Yes     |   99     | rpm-md | 

So, any thoughts?

the repos look ok…

if you wonder why i asked it is because so many folks show up here
with never seen before problems and the cause is either 1) a faulty
iso download, 2) multiple and interfering with each other repos, or 3)
user induced failures (not set up correctly, finger slips, don’t
understand, etc etc etc)…

ok, since i know that you are the only one (so far, see with this particular problem i have to
believe it is something to do with your setup, or your disk image…

did you md5sum check the image? if not, do that FIRST…instructions
to do that, if you need them are somewhere in or linked from “Download

if the image (i suppose you are running from an image, and not a CD
disk) passes then i must guess it may be something to do with your VM
or the underly, host, operating system…

i wonder if you could burn the image to disk and run the Live CD on
real hardware and see if you get any errors with Firefox…if not,
then it must be the VM or its host…right? in which case i guess you
need to find a forum of the VM maker or its host…

on the other hand, if it won’t run on your real hardware i think i run
memtest against your ram…a long time…at least over night…

check back when you can…