firefox screen corruption

Has anyone else have a problem where Firefox corrupts the screen
when it drops down menus.

This is 11.4
KDE 4.7
Nvidia blob
It does it with FF from 5.0 to nightly

This didn’t happen until today. I did KDE 4.7 a few days ago
and did another update today.

…puzzled !


Not here

Can you do a screenshot?

Flickr: whizzwheeluk’s Photostream

As I could seem to get it to attach to this reply
Ignore the two Opera screenshots - that’s me moaning at them about font issues :slight_smile:


I upgraded to fx 7 alpha (which seems pretty stable) and the problem disappeared.
Incidentally some other small niggles disappeared too.

The SUSE security updates that I installed this morning (8/3/2011) have affected my FIrefox also but not as severely as thread starter person. Foxfilre screen loads but reference to my Yahoo Home page has been dismantled. I need to delete cookies and then relogin to Yahoo to recover my home page. Upon next activation of Firefox, I get no homepage and need to go through the process again.

On opera I needed to do the same process, i.e., remove cookies and relogin to yahoo homepage and after that I get homepage. Opera does remember the info and reloads and starts homepage on subsequent restarts at least thus far.

Seems that something in the Security list of updates has indeed affected firefox and opera

Tom Kosvic

No problem here

Try a new .mozilla, just to test a plain new setup. Rename your current one, so you can switch back later

tried that ! sorry :frowning:


PS Just a thought. At home it works OK but the firefox dropdown menus don’t have fancy shadows
they are just plain blue. Once I did the updates on the machine at work firefox has posh shadowed
dropdown menus, which is what seems to get messed up. As per the previous poster I tried firefox 7
and that works fine ( with fancy shadowed dropdowns )

My home machine has Nvidia 275.19 I will update it to 280 and see what happens then do a zypper dup
and see it it’s the update that messes it up

OK, updating to Nvidia 280 didn’t make any difference
So far so good


It’s the zypper dup that munges firefox. See :-

Flickr: whizzwheeluk’s Photostream

My home machine is now the same as work. As in stuffed !

Are you using Firefox from the OBS?
If so, have you done this

I have had a break through

If you goto: System Settings/Application Appearance/GTK Styles and Fonts/GTK Styles
and select anything other than oxygen-gtk the corruption goes away ( it’s not as pretty
but you don’t get rubbish ) So I will investigate more tomorrow


It’s oxygen-gtk 1.1.1 that causes the problem
Downgrade to 1.0.5 or 1.0.1 fixes it



Using oxygen-gtk-1.1.1-3.1.x86_64 here and all is well

I’m only a lowly 32 bit user

I have tried downgrading oxygen-gtk on 3 machines now and it works everytime



Isn’t there a problem with the way KDE/kwin 4.7 does the shadow thing?
Oxygen Gtk

Yes, I eventually took the liberty of emailing the guy who wrote it and
we had an interesting conversation. If you downgrade oxygen-gtk to
1.0.5 or earlier it doesn’t corrupt the screen but you don’t get fancy
shadows. Hopefully
he will figure it out. :slight_smile:


However, oxygen-gtk 1.0.5 looks kind of boring if you’re used to the fancy newer version :frowning: .

I’m seeing the same corruption in a 11.4 64-bit running nvidia’s blob version 260 since I updated to KDE 4.7, so the issue is not restricted to 32-bit.

I’m also affected (KDE 4.7, OS 11.4, x86_64, nvidia). The fix at helps.