Firefox "save page as" not working

It’s not working no matter what webpage I view. Windows works just fine. Try “save page as” on this typical page.

Fight Spam on the Internet!

Nothing happens?? No save prompt.

It works fine for me,Check out the screenshots:-](](](

It does not help very much when you do not tell which openSUSE level and which FF level.
Do you realy expect al readers to try this whichever combination of software they might have?
This looks like the virus posted elsewhere except that it does no harm to the system.

What virus are you referring to?

Sorry, it is OOT, but it is here: Virus protection Clamav HOWTO

Actually, kidding aside, I was going to do a similar post, but never got round to it: I think this is a Firefox KDE integration issue. I have not been able to reproduce this at will, but it definitely happens after FF has been running for a while: none of the “File” (Open, Save As) dialogs pop up anymore. Stopping and restarting Firefox fixes the issue.

By the way, this also happened on 11.2 and KDE 4.3.x, but my system is now 11.3 / KDE 4.4.4 and this happens still regularly.

Does anyone have a clue on where to start looking? Is there a way to temporarily disable the FF KDE Integration to see if that’s the problem?

I can verify it is a problem here…vanilla 11.2, noscript the only add on.

Can not even save from the view source window. But you can copy and paste to a text editor then save as a work around.

I had this problem in 11.2 KDE 4.3.

So far in 11.3 KDE 4.4.4 it has not occurred.

Start Firefox in safemode and see if problem persists.

It wasn’t working for a while on the last version of suse. This version has the same problem. If you need specifics ask, I add info as is needed. I’m not always sure what is needed.

The lastest suse software updates fixed the problem. It’s working. Now, I need to find out how to change the screen saver timer. I still can’t find the location in admin or the desktop since the last version of suse. :wink:

The menu command does not work, but pressing ^S brings the dialogue box.

That would be really funny - I don’t think I tried the keyboard shortcut. I’ll post back when this happens again to see if the keyboard shortcut is a workaround.

The latest update seems to have fixed it here.

OK - possibly stupid comment here: which latest update? I don’t recall a FF update since I upgraded to 11.3…My “About” reports:

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100626 SUSE/3.6.6-1.2 Firefox/3.6.6

Is this the latest, or is there a more recent update than that?

I have Firefox 3.6.8 here in openSUSE 11.2.

I have opensuse 11.3(11.2 has the same problem). I tried disabling all my plugins. No effect. plugins: adblock, better privacy, flash video downloader, open suse firefox extentions. Firefox version: 3.6.8

The problem is random, mostly not working. Another webpage same problem:
Crysis for PC Cheats - Crysis Codes - Crysis Cheat Codes, FAQs, Walk-Throughs, Hints

I roll the dice every time I try to use it. :stuck_out_tongue:

(can’t edit last post)

I have opensuse 11.3(11.2 has the same problem). I tried disabling all my plugins. No effect. The keyboard shortcut works. :slight_smile: Thanks.