firefox print dialog show all network printers

on my Laptop=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz running opensuse leap 42.3, plasma 5.11.0, KDE frameworks 5.38.0, KDE applications 17.08.1, Kernel 4.4.87-25-default, nvidia drivers, libreoffice 5.3.5.2.
firefox 52.4.0 (64-bit) print dialog shows all the printers in the network!!
I have not all this printers installed, I would like to have only the installed printers, how can I have this??
manythanks, ciao, pier :slight_smile:
http://paste.opensuse.org/view/download/87124315

What is CUPS indicating with respect to known printer queues?

Are all the indicated printers really available on your LAN? Or, is there an issue with the Firewall of your IP/DSL Router?

This is down to cups-browsed AFAIU, which uses Avahi to discover network printer broadcasts.

In /etc/cups/cups-browsed.conf there is

 Which protocols will we use to discover printers on the network?
# Can use DNSSD and/or CUPS and/or LDAP, or 'none' for neither.

BrowseRemoteProtocols DNSSD

If desired, change it to

BrowseRemoteProtocols none

then restart cups-browsed.

yes, they are all really available printer in the lan where I was, but before today never happened…

now here it is set to

BrowseRemoteProtocols DNSSD,CUPS

I can try tomorrow, …but I have three remote printers installed, if I set it to none, does cups allow me to print with these installed printers??

When you configured them in CUPS, I assume it will be possible to user them as always.

And about the fact that CUPS now find them which wasn’t the case earlier, you should of course try to remember what changed on the system in that time frame. We can only help with that if we have an idea what changed in the system, or maybe in the printers (are you the printer and/or network manager?).

As long as they are configured in /etc/cups/printers.conf then they should work as always (as Henk already mentioned).

yes, but I didn’t installed/configured all these printers, and I used the yast>configure printer to install the three printers I use (I suppose it use CUPS)

I’m only a user, I’m not printer and/or network manager, and from when CUPS didn’t find printers on the LAN and now I didn’t changed anything in my leap 42.3, I only updated…

I modified /etc/cups/cups-browsed.conf as follow:

# Which protocols will we use to discover printers on the network?
# Can use DNSSD and/or CUPS and/or LDAP, or 'none' for neither.

# BrowseRemoteProtocols DNSSD,CUPS #2017-10-20ott this was the original
# 2017-10-20ott the one belw here modified by me
BrowseRemoteProtocols none

but firefox printer dialog box continue to show a lot of LAN printers

of course I rebooted :slight_smile:

You might need to investigate stopping/disabling the avahi-daemon.service if it really bothers you.

and how can I stop or disable it??

…it seems that only firefox and gimp are affected, becouse libreoffice and okular shows only the installed printers

This might work for you. Open /etc/avahi/avahi-daemon.conf in an editor, and locate the commented entry ‘#enable-dbus=yes’. Uncomment it and make it

enable-dbus=no

then restart avahi-daemon with

sudo systemctl restart avahi-daemon

Reference:
https://lists.debian.org/debian-user/2017/09/msg01005.html

I’m not sure about the total ramifications here though. YMMV.

I have always switched off the avahi daemon.
YaST > System > Services Manager

or disable it from the CLI with

systemctl disable avahi-daemon

Yes of course, but the advantage of YaST is that you then can easily find the correct name of the service, where with the CLI you have to know if it is avahidaemon, avahi-daemon, AvahiDaemon or other.

Also when using YaST you will see there is another service with the string avahi in it’s name: avahi-dnsconfd (in an openSUSE 31.1 btw). It is also switched off in my case.I am not sure you will detect that when using the CLI.

systemctl list-unit-files --type=service
UNIT FILE                                  STATE   
accounts-daemon.service                    disabled
after-local.service                        static  
alsa-restore.service                       static  
alsa-state.service                         static  
alsasound.service                          static  
apparmor.service                           enabled 
atd.service                                disabled
auditd.service                             enabled 
auth-rpcgss-module.service                 static  
autofs.service                             disabled
autovt@.service                            enabled 
autoyast-initscripts.service               disabled
avahi-daemon.service                       enabled 
avahi-dnsconfd.service                     disabled
.
.
.

# systemctl status avahi-dnsconfd
● avahi-dnsconfd.service - Avahi DNS Configuration Daemon
   Loaded: loaded (/usr/lib/systemd/system/avahi-dnsconfd.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

Yes, of course, of course. And a | grep -i avahi after it will also restrict output to that what you need.

But YaST will be intuitive to the user and lazy me can refrain from telling how to find avahi related services with systemctl and then how to switch it off/disable it. It is all very clear for most (even CLI fans like you and me) in the YaST window. :slight_smile:

manythanks guys :slight_smile: I disabled avahi (YaST > System > Services Manager is more simple to remember and to re-enable if for some case that I don’t know avahi is implied in any other digged thing :slight_smile: ) and it works now, at home I’m not in a big lan but before to disable avahi I saw a strange printer that now I don’t, I will try on monday when I will be in a big LAN.
…Have I to re-enable the

BrowseRemoteProtocols DNSSD

in /etc/cups/cups-browsed.conf ???