Firefox "Open in System Viewer" does not work anymore

The problem started I think some weeks ago, Firefox “Open in System Viewer” does not work anymore, that is it does not open Okular for a downloaded .pdf

https://paste.opensuse.org/images/49200656.png

Open Containing Folder works (Dolphin is opened with the relevant file selected) and that is a work-around but after “Open in System Viewer” nothing happens.

In the Firefox Preferences I have configure Firefox to save .pdf’s and that is what I want, I then like to open it with the system viewer.

https://paste.opensuse.org/images/60170186.png

Firefox is “Firefox for openSuse”, “openSUSU - Tumbleweed”, version 88.0.1 (64 bit)

Next I check the KDE System Settings -> Applications -> File Associations and as far I know that is also fine, Okular is the first preferred application:

https://paste.opensuse.org/images/93957720.png

I like to know if this is a problem on the Firefox side or on the KDE side but not sure how to further debug this.

Would be good to know if this works for others.

Open in System Viewer working as expected here with FF 88.0.1

Edit:

Only (FF) setting I may have different is General -> Applications -> PDF is set to “Always Ask”

Just tried changing the Firefox action for PDF to “Save File” and… “Open in System Viewer” still works as expected.

Thanks for checking, that points for me to a problem at the KDE side.

Found using the Internet that there is a way to open files from the command line using “kde-open5 <pdf-file>” and did give that a try.
That gave me an error related to FoxitReader (that I did installed for large pdf documents where Okular is slow) and checking things I saw the install was gone, not sure why.

Then installed the FoxitReader again tried kde-open5 again and saw Foxit was opened with the .pdf
Next I checked again the KDE settings and saw Foxit was the first preference for .pdf. Changed it back to Okular and then kde-open5 was opening Okular.

With that also “Open in System Viewer” works again in Firefox, problem solved!

I had still a Tab open and found that instead of kde-open5, there is a more generic way:

[FONT=courier new]xdg-open filename
[/FONT]
Quite handy, will likely use that more often.

OK - Good to know you’ve found the problem. :slight_smile: