Firefox not working after update

yesterday I install some updates (via the KDE update applet) on my x86_64 11.2 installation (final version). Since then firefox refuse to open some pages and also the openSUSE start pages looking strange (no graphics).
Is here a known issue with the last provided updates ?

Was your 11.2 installation an upgrade from 11.1, or fresh install? There was a post yesterday where the 11.1 to 11.2 upgrade caused a specific issue that caused all links to go back to your start page.

> Was your 11.2 installation an upgrade from 11.1, or fresh install

Fresh install.

Try doing this in a terminal:

report the output

OK starting firefox from a terminal gives:

kkeil@kke240:~> firefox
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).

Try renaming your .mozilla folder to .mozilla-old

Start FF
It will be completely clean / fresh
Does it work

This sounds related to this issue:

I solved the issue by upgrading firefox to the one in the “openSUSE BuildService - Mozilla” repository.

No, this was the first thing I tried.I cannot open any other page, but the start page (which is the page about the Firefox update).
Currently I’m running a user local copy of the 32 bit upstream version without any issues yet, but I think the root cause of that issue should be discovered.

Yes I think that is related (also in bugzilla
As workaround I’m running a local copy of the mainstream firefox version.

Do you have gecko-mediaplayer installed? It doesn’t look like it, but just checking?!

No, I do not have gecko-mediaplayer installed.

I was a default install with

  • commandline tools
  • generic C/C++ development
  • kernel-development
  • build system

as extra selections.

The only additional packages not from 11.2 openSUSE main repo are from Packman the codecs and libs to play MP3 with amarok.
But after installing these, Firefox was still working for me, the trouble started after last online update.

So did you try the build service Mozilla repo?
Then use the Package switcher

I don’t know if it’s related, but I had a similar problem. It’s gone after deactivating the “Name Service Cache Daemon” nscd in YaST runlevel editor.

That do not help.I do not know Package switcher, so I did it manually:

That do not help as well.

I also updated firefox manually through yast. These were the steps that I used:

  1. go to Yast/Software Repositories and click to add Community repositories
  2. Add the “openSUSE Build Service Mozilla” repository. For me, this service did not have any reference to factory; the url for this is “
  3. go to Yast/Software Management and change to view from search mode to repository mode; then select the openSUSE Build Service Mozilla repostory
  4. you should see a set of firefox related packages on right; above the list of packages, you should see the following hyperlink “Switch system packages to the version in the repository (openSUSE BuildService - Mozilla)”. click on the hyperlink and yast will update the list of packages to upgrade mode.
  5. click on accept to install

These are the steps I used. Hope they help,

Finally the issue is solved for me. The reason for the strange behavior was some wrong settings in the KDE proxy config. It was set to “manual config”, but no proxies were defined. Together with the openSuSE Firefox default (use system settings) for proxy this caused the trouble. After changing it to direct connection, firefox is working well.
I have no idea, what caused this wrong setting, since the dialog do not allow to safe such settings (and I never touched them).